glassfish
  1. glassfish
  2. GLASSFISH-18930

standalone thick iiop client fails to load classes (for ex- javax/ejb/CreateException)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0_b76_EE7MS5
    • Component/s: orb
    • Labels:
      None

      Description

      Prior to build b46 our standalone IIOP client ran fine with following command,

      java -Xms256m -Xmx512m -Dcom.sun.corba.ee.ORBFragmentReadTimeout=1200000 -Djava.naming.factory.initial=com.sun.enterprise.naming.SerialInitContextFactory -Djava.naming.provider.url=iiops://perf-x4150-1:3820 -Djava.naming.provider.url.pkgs=com.sun.enterprise.naming -Dorg.omg.CORBA.ORBInitialHost=perf-x4150-1 -Dorg.omg.CORBA.ORBInitialPort=3700 -cp $GLASSFISH_HOME/modules/gf-client-module.jar:build weblogic.performance.benchmarks.rmi.clients.RMIBenchmarksClient -propsfile gstr1k.props

      $GLASSFISH_HOME/modules/gf-client-module.jar in classpath made other glassfish related classes to be loaded. But from b46 we get following exception,

      Exception in thread "main" java.lang.NoClassDefFoundError: javax/ejb/CreateException
      at weblogic.performance.benchmarks.rmi.clients.RMIBenchmarksClient.<init>(RMIBenchmarksClient.java:64)
      at weblogic.performance.benchmarks.rmi.clients.RMIBenchmarksClient.main(RMIBenchmarksClient.java:203)
      Caused by: java.lang.ClassNotFoundException: javax.ejb.CreateException
      at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      ... 2 more

      All our IIOP benchmarks fail due to this.

        Activity

        Harshad Vilekar added a comment -

        Amit, I tried your Perf Benchmark IIOP client with the recent promoted build 76, and couldn't duplicate this issue. Please update if you still see this issue with B76.

        amitagarwal added a comment -

        This problem persists in b47 too. Unable to run IIOP benchmarks at all, hence changing the priority to Blocker.


          People

          • Assignee:
            Harshad Vilekar
            Reporter:
            amitagarwal
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: