glassfish
  1. glassfish
  2. GLASSFISH-18939

The result of asadmin set resources.mail-resource.mail/testa.enabled=false not shown in the GUI

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b45
    • Fix Version/s: 4.0_b78, 4.0
    • Component/s: admin_gui
    • Labels:
      None

      Description

      The result of asadmin set resources.mail-resource.mail/testa.enabled=false not shown in the GUI

      1.When a user executes the following command, the status is still shown as Enabled in the GUI. (Please see the screenshot.)

      C:\>asadmin set resources.mail-resource.mail/testa.enabled=false
      resources.mail-resource.mail/testa.enabled=false
      Command set executed successfully.

      2. When a user executes the following command, the status in the GUI becomes Disabled or Enabled.

      C:\>asadmin set server.resource-ref.mail/testa.enabled=false
      server.resource-ref.mail/testa.enabled=false
      Command set executed successfully.
      C:\>asadmin set server.resource-ref.mail/testa.enabled=true
      server.resource-ref.mail/testa.enabled=true
      Command set executed successfully.

      I checked the domain.xml.
      When 1 is executed, the mail-resource tag in the <resource> section becomes enabled=false. When 2 is executed, the mail-resource tag in the <servers> section becomes enabled=false or true.
      I noticed the GUI only shows the status of <servers> section. The issue is when 1 is false and 2 is true, mail/testa is disabled in reality. However, the GUI shows it as enabled. That is very confusing. I think the status in the GUI needs improvement.

        Activity

        Bill Shannon added a comment -

        Reassign to admin GUI team.

        Anissa Lam added a comment -

        This is actually a bug. GUI should show the correct status by looking at both value.

        Anissa Lam added a comment -

        Issues need to be addressed before 4.0 HCF (3/25)

        Anissa Lam added a comment -

        Issue fixed.

        Log Message:
        ------------
        Fix GLASSFISH-18939. Ensure that

        • both resource and resource-ref status is 'AND' together to show real status to user
        • for DAS only case, when the resource-ref doesn't exist and user does a SAVE, create the resource-ref first.
        • the resources table also fixed to look at both resource and resource-ref status.

        Revisions:
        ----------
        59774

        Modified Paths:
        ---------------
        trunk/main/appserver/admingui/common/src/main/resources/resourceNode/resourceHandlers.inc
        trunk/main/appserver/admingui/common/src/main/resources/resourceNode/resourceEditTabs.inc
        trunk/main/appserver/admingui/common/src/main/resources/resourceNode/resourceEditPageButtons.inc


          People

          • Assignee:
            Anissa Lam
            Reporter:
            tak09
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: