glassfish
  1. glassfish
  2. GLASSFISH-18952

[regression] web test failed with empty contextpath specified in sun-web.xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 4.0_b48
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      RHL5 JDL1.6.0_30

      Description

      glassfish-4.0-b47.zip

      appserver-sqe/pe/tomcat/servlet/product_test/servlet2_5/contextpath/test1
      The same test passed on b46, but failed on b47 with 404 error.

        Activity

        sherryshen added a comment -

        Test source and war.

        sherryshen added a comment -

        To reproduce the issue
        1) deploy war from attached test1.zip
        asadmin deploy contextpath-test1.war
        2) access uri /test/TestServlet
        see "HTTP Status 404" on build 47
        see "pass" in response on build 46

        Shing Wai Chan added a comment -

        I have checkout an up-to-date workspace and the test passes.
        This may be due to build b47 picking up part of the fix for http://java.net/jira/browse/GLASSFISH-18866 .
        So, I will mark this as a duplicate of 18866.

        sherryshen added a comment -

        Test passed on glassfish-4.0-b48.zip.


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: