Issue Details (XML | Word | Printable)

Key: GLASSFISH-18965
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Joe Di Pol
Reporter: schaffer1969
Votes: 1
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
glassfish

Issue updating Glassfish 3.1.2 on Ubuntu 12.04 server

Created: 31/Jul/12 01:23 PM   Updated: 13/Feb/14 01:19 AM
Component/s: update_center
Affects Version/s: 3.1.2
Fix Version/s: None

Time Tracking:
Not Specified

Environment:

Ubuntu server 12.04


Tags: pkg updatetool Ubuntu
Participants: Joe Di Pol, schaffer1969 and Snjezana Sevo-Zenzerovic


 Description  « Hide

I have successfully installed Glassfish 3.1.2 onto Ubuntu server 12.04.
However when I try to update the server using "sudo ./bin/pkg image-update" I am prompted to install the pkg package.
It attempts to use the system proxy settings and I get the following error:

GLib-GIO-ERROR **: Settings schema 'org.gnome.system.proxy' is not installed

Obviously as a server edition it will not have gnome installed.

I have also noticed that this screws up glassfish as it fails with the same error when started.
This only occurs when I try to update glassfish after running pkg. Also there is no .updatetool/init.cgf file created where the a proxy is set.
Even if I do a fresh install of glassfish the problem exists. The running or installation of pkg must set a system variable to look for the system.proxy.



No work has yet been logged on this issue.