glassfish
  1. glassfish
  2. GLASSFISH-18971

LifecycleModule can't be listed in GUI when deployed on cluster or no specific target.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b45
    • Fix Version/s: 4.0_b78, 4.0
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Windows Xp

      Description

      [Bug Description]
      LifecycleModule can't be listed in GUI when deployed on cluster or no specific target.

      [Operations]
      1. create a cluster(cluster001),then create a lifecycle module on target cluster001(test)

      2. there's no lifecycle module listed in GUI, but you can list the lifecycle module through
      "asadmin list-lifecycle-module --target cluster001"

      [my opition]
      I think the lifecycle module should be listed in GUI when deployed on cluster or no specific target .

      [Affected versions]
      1 4.0_b45
      2 gf's trunk until 2012/07/30

        Activity

        Jeremy_Lv added a comment -

        I have two solution ideas about this issue. I wonder if you can choose one and then I'll run the QL tests and dev tests as soon as possible.

        Hong Zhang added a comment -

        Lifecycle modules maybe listed in a different screen in GUI, I will let Anissa comment on this first.

        Jeremy_Lv added a comment -

        Anissa:
        if you have cycle. pls review my revised codes which is already attached to the JIRA and tell me anything useful informations about dev tests related to admin_gui.
        Thanks.

        Anissa Lam added a comment -

        Issues need to be addressed before 4.0 HCF (3/25)

        Anissa Lam added a comment -

        thanks Jeremy_Lv for filing and try to provide a fix to the issue.
        I looked at this, the issue isn't in the list-lifecycle-modules command. The console should have called with --target domain to get all the lifecycle modules for the entire domain, just like list-applications.

        I just fixed it by adding the target domain, otherwise, the default is 'server', and thus won't show any LF thats created for other target.
        I have checked in the fix.

        Log Message:
        ------------
        fix GLASSFISH-18971. Console should pass in 'domain' as target so that list-lifecycle-modules will return all the lifecycle modules.

        Revisions:
        ----------
        59776

        Modified Paths:
        ---------------
        trunk/main/appserver/admingui/common/src/main/resources/applications/lifecycles.jsf
        trunk/main/appserver/admingui/common/src/main/resources/pluginTreeNodeApps.jsf


          People

          • Assignee:
            Anissa Lam
            Reporter:
            Jeremy_Lv
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: