glassfish
  1. glassfish
  2. GLASSFISH-18976

Missing packages in recently introduced jaxb modules

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b45
    • Fix Version/s: 4.0_b46
    • Component/s: web_services
    • Labels:
      None

      Description

      This is caused by recent JAXB integration in GlassFish. The new jaxb modules don't have some of the packages that old jaxb modules used to export. For you information, I confirm that I have considers jaxb-extra-osgi.jar as well. The difference between the sets of packages exported by old and new jaxb modules are given below (0.s refers to old packages and 1.s refers to new packages):
      Both old-packages-list.txt and new-packages-list.txt are attached as well.

      ss141213@Sahoo:/tmp/g$ diff old-packages-list.txt new-packages-list.txt
      8a9,10
      > com.sun.msv.datatype
      > com.sun.msv.datatype.regexp
      10,17c12,13
      < com.sun.msv.grammar
      < com.sun.msv.grammar.trex
      < com.sun.msv.reader
      < com.sun.msv.reader.trex.ng
      < com.sun.msv.reader.util
      < com.sun.msv.util
      < com.sun.msv.verifier
      < com.sun.msv.verifier.regexp

      > com.sun.msv.datatype.xsd.datetime
      > com.sun.msv.datatype.xsd.ngimpl
      101a98
      > com.sun.xml.util

      As you can see there are some new packages, but some are missing too. e.g. com.sun.msv.grammar is missing.

      1. new-packages-list.txt
        3 kB
        Sanjeeb Sahoo
      2. old-packages-list.txt
        3 kB
        Sanjeeb Sahoo

        Activity

        Lukas Jungmann added a comment -

        Martin, is this expected state?

        thx.

        Martin Grebac added a comment -

        Don't know, we have to check one by one - please work with Yarda on this. Thanks.

        Sanjeeb Sahoo added a comment -

        Some of the missing packages are actually needed by some bundles. One can find out more about how bundles depend on various packages by following instructions in [1].

        Because of this issue, I am seeing the following failure when I try to start GlassFish to load bundles in ondemand mode. To start server in ondemand mode, just set glassfish.osgi.ondemand=true. It's set to false by default. I am also seeing some issues on Equinox platform, but they seem to be caused by this jaxb issue and recent jersey upgrade.

        6 Aug, 2012 6:34:20 AM ObrHandler findResource
        INFO: Using the first one from the list of 1 discovered bundles shown below: [com.ctc.wstx/0.0.0]
        6 Aug, 2012 6:34:20 AM ObrHandler resolve
        INFO: At the end of first pass, resolver outcome is
        : Added resources: [
        com.ctc.wstx, 0.0.0, file:/space/ss141213/WS/gf/trunk-svn/all/main/appserver/distributions/glassfish/target/stage/glassfish3/glassfish/modules/woodstox-osgi.jar]
        Required Resources: []
        Optional resources (deployed): []
        Unsatisfied requirements: [
        package&(package=com.sun.msv.grammar.trex))
        package&(package=com.sun.msv.util))
        package&(package=com.sun.msv.verifier.regexp))
        package&(package=com.sun.msv.reader.trex.ng))
        package&(package=com.sun.msv.verifier))
        package&(package=com.sun.msv.reader.util))
        package&(package=com.sun.msv.grammar))
        package&(package=com.sun.msv.reader))]
        6 Aug, 2012 6:34:20 AM ObrHandler deploy
        WARNING: Unable to satisfy the requirements: [org.apache.felix.bundlerepository.impl.ReasonImpl@2cb491, org.apache.felix.bundlerepository.impl.ReasonImpl@199ffdd, org.apache.felix.bundlerepository.impl.ReasonImpl@1868b72, org.apache.felix.bundlerepository.impl.ReasonImpl@17cdd50, org.apache.felix.bundlerepository.impl.ReasonImpl@16d383a, org.apache.felix.bundlerepository.impl.ReasonImpl@a5b721, org.apache.felix.bundlerepository.impl.ReasonImpl@f96845, org.apache.felix.bundlerepository.impl.ReasonImpl@102d72d]
        Exception in thread "main" java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
        at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
        Caused by: org.jvnet.hk2.component.ComponentException: Failed to create a habitat
        at com.sun.enterprise.module.common_impl.AbstractModulesRegistryImpl.populateServiceLocator(AbstractModulesRegistryImpl.java:182)
        at com.sun.enterprise.module.bootstrap.Main.createServiceLocator(Main.java:284)
        at org.jvnet.hk2.osgiadapter.HK2Main.createServiceLocator(HK2Main.java:119)
        at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishRuntime.newGlassFish(EmbeddedOSGiGlassFishRuntime.java:98)
        at com.sun.enterprise.glassfish.bootstrap.GlassFishRuntimeDecorator.newGlassFish(GlassFishRuntimeDecorator.java:68)
        at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntime.newGlassFish(OSGiGlassFishRuntime.java:93)
        at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:113)
        ... 6 more
        Caused by: java.lang.RuntimeException: Unable to install module [ OSGiObrModuleImpl::Name: [com.ctc.wstx], State: [NEW]] due to unsatisfied dependencies. See previous log messages.
        at org.jvnet.hk2.osgiadapter.OSGiObrModuleImpl.init(OSGiObrModuleImpl.java:86)
        at org.jvnet.hk2.osgiadapter.OSGiObrModuleImpl.parseInhabitants(OSGiObrModuleImpl.java:171)
        at org.jvnet.hk2.osgiadapter.AbstractOSGiModulesRegistryImpl.parseInhabitants(AbstractOSGiModulesRegistryImpl.java:102)
        at com.sun.enterprise.module.common_impl.AbstractModulesRegistryImpl.populateServiceLocator(AbstractModulesRegistryImpl.java:178)
        ... 12 more

        [1] https://wikis.oracle.com/display/GlassFish/OsgiPkgDepAnalyser

        Lukas Jungmann added a comment -
        Sanjeeb Sahoo added a comment -

        verified the fix. thanks.


          People

          • Assignee:
            Lukas Jungmann
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: