glassfish
  1. glassfish
  2. GLASSFISH-18982

Seeing SAAJ regressions in GFV4.0 Build 49 dated 08/03/2012

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b39
    • Fix Version/s: 4.0_b60
    • Component/s: grizzly-kernel
    • Labels:
      None
    • Environment:

      ALL Platforms

      Description

      I am getting 8 saaj regressions in latest CTS run with GFV4.0 Build 49 dated 08/03/2012. I will attach the run log and server log.

      The regressions are:

      [javatest.batch] FAILED........com/sun/ts/tests/saaj/api/javax_xml_soap/SOAPMessage/URLClient.java#setConte
      ntDescriptionTest
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/SendVariousMimeAttachments/URLClient.java#SendVario
      usMimeAttachmentsSOAP11Te
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/SendVariousMimeAttachments/URLClient.java#SendVario
      usMimeAttachmentsSOAP12Te
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachments
      SOAP11Test_from_appclient
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachments
      SOAP11Test_from_jsp
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachments
      SOAP12Test_from_appclient
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachments
      SOAP12Test_from_jsp
      [javatest.batch] FAILED........com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachments
      SOAP12Test_from_servlet

      1. full_runclient_unix.log
        7.30 MB
        alanf760
      2. full_server.log
        1.76 MB
        alanf760
      3. runclient_unix.log
        204 kB
        alanf760
      4. server.log
        111 kB
        alanf760

        Activity

        Ryan Lubke added a comment -

        To save time:

        Caused by: org.glassfish.grizzly.PendingWriteQueueLimitExceededException: Max queued data limit exceeded: 114760>100872
        at org.glassfish.grizzly.nio.AbstractNIOAsyncQueueWriter.checkQueueSize(AbstractNIOAsyncQueueWriter.java:620)
        at org.glassfish.grizzly.nio.AbstractNIOAsyncQueueWriter.writeQueueRecord(AbstractNIOAsyncQueueWriter.java:280)
        at org.glassfish.grizzly.nio.AbstractNIOAsyncQueueWriter.write(AbstractNIOAsyncQueueWriter.java:219)
        at org.glassfish.grizzly.nio.transport.TCPNIOTransportFilter.handleWrite(TCPNIOTransportFilter.java:127)
        at org.glassfish.grizzly.filterchain.TransportFilter.handleWrite(TransportFilter.java:191)
        at org.glassfish.grizzly.filterchain.ExecutorResolver$8.execute(ExecutorResolver.java:111)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:265)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
        at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
        at org.glassfish.grizzly.filterchain.FilterChainContext.write(FilterChainContext.java:652)
        at org.glassfish.grizzly.http.server.io.OutputBuffer.writeContentBuffer0(OutputBuffer.java:867)
        at org.glassfish.grizzly.http.server.io.OutputBuffer.write(OutputBuffer.java:602)
        at org.apache.catalina.connector.OutputBuffer.writeBytes(OutputBuffer.java:351)
        at org.apache.catalina.connector.OutputBuffer.write(OutputBuffer.java:338)
        at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputStream.java:161)
        at javax.activation.DataHandler.writeTo(DataHandler.java:309)
        at com.sun.xml.messaging.saaj.packaging.mime.internet.MimeBodyPart.writeTo(MimeBodyPart.java:976)
        at com.sun.xml.messaging.saaj.packaging.mime.internet.MimeMultipart.writeTo(MimeMultipart.java:292)
        at com.sun.xml.messaging.saaj.soap.MessageImpl.writeTo(MessageImpl.java:1337)

        Ryan Lubke added a comment -

        Is this still an issue with the current weekly promoted builds?

        Lukas Jungmann added a comment -

        no, I believe this is fixed, I'm not seeing any failures (related to this issue) in test job

        oleksiys added a comment -

        fixed


          People

          • Assignee:
            oleksiys
            Reporter:
            alanf760
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: