glassfish
  1. glassfish
  2. GLASSFISH-18983

Startup of node in cluster fails due to "jms is currently in restricted service mode"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Works as designed
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Ubuntu 12.04 server edition, 64 bit

      Description

      GF 3.1.2 (build 23), Ubuntu 12.04 server edition

      I have a Glassfish cluster consisting of 2 machines as follows
      192.168.0.20 - DAS, i1
      192.168.0.23 - i2

      The i2 node fails at startup with
      A broker error occurred. :[503] [B4286]: [Thread-jms[0]]Auto-creation of destination TagUpdatesIn is not allowed because service jms is currently in restricted service mode: Persistent store has not been synchronized with master broker [broker2(mq://192.168.0.23:27676/)] user=guest, broker=localhost:27677(33191)|#]

      I've tried the solutions suggested in issue-14788 and this has not resolved the issue.

      I've attached logs for both instances, the imq logs and the cluster domain.xml file.

      Is instance i2 trying to connect to itself as a master broker?

        Activity

        schaffer1969 added a comment -

        Adding logs again as they did not seem to load first time

        David Zhao added a comment -

        That is the configuration issue.

        The instance i1 is created on node localhost-domain1 which node-host is localhost. Then the master broker of i2 becomes "mq://localhost:27676/", but the localhost here is expected by MQ to be the real hostname or ip address of the machine where the DAS and i1 reside on. In a jms conventional cluster, MQ brokers rely on the correct master broker address to sync persistent store.

        localhost-domain1 is a predefined CONFIG node of domain1 on the host where the DAS is running, this node represents the local host. For your case, it is expected to create a new node for i1 with corresponding [--nodehost node-host] except localhost, and to keep i2 unchanged.

        The existing nodes can be checked by "asadmin list-nodes --long", and you can create local config node by "asadmin create-node-config --nodehost 192.168.0.20 [--installdir install-dir] [--nodedir node-dir] node-name".

        I guess GLASSFISH-18966 could be caused by the same reason. Please check it again and let me know.


          People

          • Assignee:
            David Zhao
            Reporter:
            schaffer1969
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: