Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b49
    • Fix Version/s: None
    • Component/s: hk2
    • Labels:
      None

      Description

      Embedded Server cannot be started using the glassfish-embedded-all.jar from the trunk. It seem to be related to recent hk2 update.

      GlassFish glassfish = GlassFishRuntime.bootstrap().newGlassFish();
      glassfish.start();

      Exception in thread "main" org.glassfish.embeddable.GlassFishException: com.sun.enterprise.module.bootstrap.BootException: Cannot find null ModuleStartup
      at com.sun.enterprise.glassfish.bootstrap.StaticGlassFishRuntime.newGlassFish(StaticGlassFishRuntime.java:149)
      at SimpleTest.main(SimpleTest.java:60)
      Caused by: com.sun.enterprise.module.bootstrap.BootException: Cannot find null ModuleStartup
      at com.sun.enterprise.module.bootstrap.Main.findStartupService(Main.java:227)
      at com.sun.enterprise.glassfish.bootstrap.StaticGlassFishRuntime.newGlassFish(StaticGlassFishRuntime.java:117)

        Activity

        mtaube added a comment -

        when building the distribution, maven-antrun-extended-plugin is not concatenating hk2 descriptor files. maven-antrun-extended-plugin needs to be updated to account for this.


          People

          • Assignee:
            mtaube
            Reporter:
            Amy Roh
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: