glassfish
  1. glassfish
  2. GLASSFISH-18990

[PERF] JServlet2 HTTP/Servlet micro benchmark using in-memory session replication shows Timeout Exceptions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b41
    • Fix Version/s: None
    • Component/s: failover
    • Labels:
      None
    • Environment:

      Intel(R) Xeon(R) 8-CPU E5450 @ 3.00GHz 32GB
      Linux 2.6.18-164.el5xen #1 SMP Thu Sep 3 04:41:04 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

      Description

      When running Web micro benchmark configured to use session replication among two instances of glassfish 4.0, getting a lot of warnings with timeout exception after a few minutes of starting performance test:

      [#|2012-08-02T23:15:26.497-0700|WARNING|44.0|org.shoal.ha.cache.command.load_request|_ThreadID=106;_ThreadName=Thread-2;|LoadRequestCommand timed out while waiting for result java.util.concurrent.TimeoutException|#]

      There are no other errors/exceptions in log files to indicate source of this or any other problem.

        Activity

        deep_singh added a comment -

        This issue is resolved with integration of Grizzly 2.2.13 in Glassfish 4.0 b49 . The bug was due to wrong value for cookie which tracks version number for a replicated session. With the bug fix, the glassfish regression between Glassfish 3.1.2 and Glassfish 4.0 has come down from 44% (in b48) to 11% (in b49; as reported by Alacrity).


          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            deep_singh
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: