Issue Details (XML | Word | Printable)

Key: GLASSFISH-19018
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: marina vatkina
Reporter: sherryshen
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

tx recovery tests failed due to ClassCastException: initRecovery

Created: 17/Aug/12 03:32 PM   Updated: 18/Aug/12 01:11 AM   Resolved: 17/Aug/12 07:09 PM
Component/s: jts
Affects Version/s: 4.0_b50_ms4
Fix Version/s: 4.0_b51

Time Tracking:
Not Specified

Environment:

RHL5 JDK1.7.0_03


Tags: 40-regression
Participants: marina vatkina and sherryshen


 Description  « Hide

The tx recovery tests are very slow in execution and have failure on glassfish-4.0-b50.zip.

One example:
appserver-sqe/pe/transaction/recovery/cliweb4
[exec] asadmin recover-transactions --target clustered_instance_1 clustered_instance_2
[exec] No response from Domain Admin Server after 600 seconds.
....
[java] - tx-cliweb4-t1-killASInstanceAdmincliDelegatedRecovery: FAIL -

http://sqe-hudson.us.oracle.com:8080/hudson/job/sherry-lc-dbg/159/artifact/server_in1.log

[#|2012-08-16T21:08:27.749-0700|WARNING|44.0|
javax.enterprise.system.core.org.glassfish.kernel.event|_ThreadID=10;_ThreadName=Thread-2;|
Exception while dispatching an event
java.lang.ClassCastException:
org.jvnet.hk2.internal.ServiceLocatorImpl cannot be cast to org.jvnet.hk2.component.Habitat
at com.sun.jts.jta.TransactionServiceProperties.initRecovery(TransactionServiceProperties.java:313)

[#|2012-08-16T21:24:41.431-0700|SEVERE|44.0|javax.enterprise.resource.jta.com.sun.enterprise.transaction|
_ThreadID=16;_ThreadName=Thread-2;|DTX5016:Error in XA recovery. See logs for more details
org.omg.CORBA.INTERNAL: JTS5005: Wait for resync complete interrupted vmcid: 0x0 minor code: 0 completed: No
at com.sun.jts.CosTransactions.RecoveryManager.waitForResync(RecoveryManager.java:1479)

The same test passed on glassfish-4.0-b49.zip.



sherryshen made changes - 17/Aug/12 03:34 PM
Field Original Value New Value
Affects Version/s 4.0_b50_ms4 [ 15639 ]
Affects Version/s 4.0_b49 [ 15638 ]
sherryshen made changes - 17/Aug/12 03:36 PM
Tags 40-regression
sherryshen added a comment - 17/Aug/12 07:09 PM

The test of tx-cliweb4-t1-killASInstanceAdmincliDelegatedRecovery
passed on the glassfish-4.0-b51-08_17_2012.zip with the fix below.

#11813 (Aug 16, 2012 9:31:11 AM)
55511 Habitat can't be casted to ServiceLocator any more.
This should fix the clustered tx tests. mvatkina / detail


sherryshen made changes - 17/Aug/12 07:09 PM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 4.0_b51 [ 15640 ]
Resolution Fixed [ 1 ]
sherryshen made changes - 18/Aug/12 01:10 AM
Summary tx recovery tests slow and fail 4.0 b50 tx recovery tests failed due to ClassCastException: nitRecovery
Description The tx recovery tests are very slow in execution and have failure on glassfish-4.0-b50.zip.

One example:
appserver-sqe/pe/transaction/recovery/cliweb4
  [exec] asadmin recover-transactions --target clustered_instance_1 clustered_instance_2
  [exec] No response from Domain Admin Server after 600 seconds.
  ....
  [java] - tx-cliweb4-t1-killASInstanceAdmincliDelegatedRecovery: FAIL -

http://sqe-hudson.us.oracle.com:8080/hudson/job/sherry-lc-dbg/159/artifact/server_in1.log
[#|2012-08-16T21:24:41.431-0700|SEVERE|44.0|javax.enterprise.resource.jta.com.sun.enterprise.transaction|
_ThreadID=16;_ThreadName=Thread-2;|DTX5016:Error in XA recovery. See logs for more details
org.omg.CORBA.INTERNAL: JTS5005: Wait for resync complete interrupted vmcid: 0x0 minor code: 0 completed: No
at com.sun.jts.CosTransactions.RecoveryManager.waitForResync(RecoveryManager.java:1479)

The same test passed on glassfish-4.0-b49.zip.
The tx recovery tests are very slow in execution and have failure on glassfish-4.0-b50.zip.

One example:
appserver-sqe/pe/transaction/recovery/cliweb4
  [exec] asadmin recover-transactions --target clustered_instance_1 clustered_instance_2
  [exec] No response from Domain Admin Server after 600 seconds.
  ....
  [java] - tx-cliweb4-t1-killASInstanceAdmincliDelegatedRecovery: FAIL -

http://sqe-hudson.us.oracle.com:8080/hudson/job/sherry-lc-dbg/159/artifact/server_in1.log

[#|2012-08-16T21:08:27.749-0700|WARNING|44.0|
javax.enterprise.system.core.org.glassfish.kernel.event|_ThreadID=10;_ThreadName=Thread-2;|
Exception while dispatching an event
java.lang.ClassCastException:
org.jvnet.hk2.internal.ServiceLocatorImpl cannot be cast to org.jvnet.hk2.component.Habitat
at com.sun.jts.jta.TransactionServiceProperties.initRecovery(TransactionServiceProperties.java:313)



[#|2012-08-16T21:24:41.431-0700|SEVERE|44.0|javax.enterprise.resource.jta.com.sun.enterprise.transaction|
_ThreadID=16;_ThreadName=Thread-2;|DTX5016:Error in XA recovery. See logs for more details
org.omg.CORBA.INTERNAL: JTS5005: Wait for resync complete interrupted vmcid: 0x0 minor code: 0 completed: No
at com.sun.jts.CosTransactions.RecoveryManager.waitForResync(RecoveryManager.java:1479)


The same test passed on glassfish-4.0-b49.zip.
sherryshen made changes - 18/Aug/12 01:11 AM
Summary tx recovery tests failed due to ClassCastException: nitRecovery tx recovery tests failed due to ClassCastException: initRecovery