glassfish
  1. glassfish
  2. GLASSFISH-19032

Invalid Chunk header while running web services on Glassfish 3.1.2

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 3.1.2_b23
    • Fix Version/s: None
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      RHEL 5.4 / glassfish 3.1.2 / jdk1.6_11

      Description

      Receiving invalid chunk header

      [#|2012-08-22T17:03:54.717-0400|SEVERE|oracle-glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=47;_ThreadName=Thread-2;|org.apache.axis2.AxisFault: Invalid chunk header
      at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:512)
      at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:370)
      at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:416)
      at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:228)
      at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
      at eTrace.webservice.userServices.GUIDGeneratorWSStub.generateGUID2013(GUIDGeneratorWSStub.java:461)
      at org.apache.jsp.sam.testGuidHEB_jsp._jspService(testGuidHEB_jsp.java from :137)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:111)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:411)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:473)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:377)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1550)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:343)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:217)
      at com.reflexis.filters.RfxSecurityFilter.doFilter(Unknown Source)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:256)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:217)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:279)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:331)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
      at com.sun.enterprise.v3.services.impl.ContainerMapper$AdapterCallable.call(ContainerMapper.java:317)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:195)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:860)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:757)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1056)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:229)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)

      #]

        Activity

        Lukas Jungmann added a comment - - edited

        Hi, can you provide (attach to this issue) some simple application for reproducing this issue? Without that it is hard to say what's wrong and where. Also can you try to reproduce the issue with latest GlassFish 3.1.2.2 (available from http://glassfish.java.net/downloads/3.1.2.2-final.html)?

        Thanks.

        talk2umakanth added a comment -

        Our build is deployed on Glass fish 3.1.2.2 (build 5). We updated it yesterday

        Lukas Jungmann added a comment -

        ok. But still I don't know how can I help you without more info (I need to get at least one line from a stacktrace starting either with com.sun.xml.ws or org.glassfish.webservices prefix - it may not be enough but it's worth trying) or reproducible testcase. I even cannot see anything related to Metro/JAX-WS RI in the stacktrace. Top lines in a stacktrace are comming from Axis, so I'd try to get help there first... http://axis.apache.org/axis/bugs.html

        Lukas Jungmann added a comment -

        incomplete for now

        talk2umakanth added a comment - - edited

        I think we figured out the cause of the problem.

        Test Case 1

        • We have the WSDL for a webservice and if we call the SOAP endopoint through the webserver and hit a webserver port like 80, Invalid Chunk header is thrown

        The below does not work
        http://192.168.1.171:80/RTMHEBSB/services/GUIDGeneratorWS.GUIDGeneratorWSHttpSoap12Endpoint

        Test Case 2


          People

          • Assignee:
            Lukas Jungmann
            Reporter:
            talk2umakanth
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: