Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0_b53
    • Component/s: jts
    • Labels:
      None

      Description

      I don't know when it started happening and which change caused it, but this stack trace is seen in many logs in tx recovery tests:

      [#|2012-09-05T06:34:37.175-0700|WARNING|44.0|javax.enterprise.system.core.transaction.com.sun.enterprise.transaction.jts.recovery|_ThreadID=10;_ThreadName=main;|jts.exception_in_recovery_file_handling
      java.io.IOException: No such file or directory
      at java.io.UnixFileSystem.createFileExclusively(Native Method)
      at java.io.File.createNewFile(File.java:883)
      at com.sun.enterprise.transaction.jts.recovery.RecoveryLockFile.init(RecoveryLockFile.java:123)
      at com.sun.enterprise.transaction.jts.recovery.RecoveryLockFile.getDelegatedTransactionRecoveryFence(RecoveryLockFile.java:104)
      at com.sun.enterprise.transaction.jts.recovery.GMSCallBack.<init>(GMSCallBack.java:107)
      at com.sun.enterprise.transaction.jts.JavaEETransactionManagerJTSDelegate.initTransactionProperties(JavaEETransactionManagerJTSDelegate.java:551)
      at com.sun.enterprise.transaction.jts.JavaEETransactionManagerJTSDelegate.postConstruct(JavaEETransactionManagerJTSDelegate.java:142)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:249)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:288)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:410)
      at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:86)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:156)
      at org.jvnet.hk2.internal.ServiceLocatorImpl.getAllServices(ServiceLocatorImpl.java:429)
      at com.sun.enterprise.transaction.JavaEETransactionManagerSimplified.initDelegates(JavaEETransactionManagerSimplified.java:1492)
      at com.sun.enterprise.transaction.JavaEETransactionManagerSimplified.postConstruct(JavaEETransactionManagerSimplified.java:165)

        Activity

        marina vatkina added a comment -

        The cause: log dir hadn't been created prior to RecoveryLockFile creation.

        marina vatkina added a comment -

        Fixed with rev 55818. The test uses build directory as the tx log dir (there are 3 tests like that), and the logdir is not created properly when the recovery lock file is created.


          People

          • Assignee:
            marina vatkina
            Reporter:
            marina vatkina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: