Issue Details (XML | Word | Printable)

Key: GLASSFISH-19073
Type: Bug Bug
Status: Resolved Resolved
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Byron Nevins
Reporter: KSchumann
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

Creation of OS Service getting fail on Windows Terminal Server SP1

Created: 13/Sep/12 03:22 PM   Updated: 26/Feb/13 11:20 PM   Resolved: 26/Feb/13 11:20 PM
Component/s: admin
Affects Version/s: None
Fix Version/s: 4.0

Time Tracking:
Not Specified

Environment:

Windows 2008 R2


Tags: 3-1-regression
Participants: Byron Nevins, KSchumann and Snjezana Sevo-Zenzerovic


 Description  « Hide

Steps :

1) Install 3.1B34 glassfish sever on windows 2008 machine and Enable "Create OS Service for domain1" - default name "domain1Service".

2) During the creation of OS Service , command create service fails with below error.

Executing command :C:\glassfish3b34\glassfish\bin\asadmin.bat create-service --name B34domain1Service domain1
Command create-service failed.
Error while trying to install GlassFish as a Windows Service.
The return value was: 8.
STDERR:
STDOUT: WMI.WmiException: UnknownFailure
at WMI.WmiRoot.BaseHandler.CheckError(ManagementBaseObject result)
at WMI.WmiRoot.ClassHandler.Invoke(Object proxy, MethodInfo method, Object[] args)
at WMI.Win32ServicesProxy.Create(String , String , String , ServiceType , ErrorControl , StartMode , Boolean , String[] )
at winsw.WrapperService.Run(String[] args)
at winsw.WrapperService.Main(String[] args)



KSchumann added a comment - 13/Sep/12 03:29 PM

The only difference for me is I am using Glassfish-3.1.2-windows.exe, using remote dekstop to a Terminal Server... but I still get this error.


Byron Nevins added a comment - 18/Feb/13 05:49 PM

create-service works fine. I checked. The problem is in the installer.

Easy fix – simply run the create-service command after installation.


KSchumann added a comment - 18/Feb/13 08:44 PM

It is not quite so simple, as the error exists when the create-service command line is used also...


Snjezana Sevo-Zenzerovic added a comment - 26/Feb/13 10:32 PM

Reassigning since submitter reports that the issue is not limited to install time service creation.


Byron Nevins added a comment - 26/Feb/13 10:49 PM

Are you sure that you have Administrator privileges when you ran the command?


Byron Nevins added a comment - 26/Feb/13 11:20 PM

I can't reproduce this. It works fine for me.