glassfish
  1. glassfish
  2. GLASSFISH-19074

Problem related to admin console happened on server.log after loading admin console

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b55
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      1 Windows XP
      2 GF trunk 2012/09/14

      Description

      1 updating to gf trunk 2012/09/14 and building gf

      2 starting domain and loading admin console

      3 after loading admin console, on server.log, the following exception happened, although admin console can be accessed normally. (can not find commons-io-1.3.1.jar)

      [#|2012-09-14T12:04:14.875+0900|WARNING|44.0|org.apache.jasper.runtime.TldScanner|_ThreadID=21;_ThreadName=Thread-22;|PWC6351: In TLD scanning, the supplied resource file:/E:/gf0914/glassfish3/glassfish/lib/install/applications/__admingui/WEB-INF/extra/commons-io-1.3.1.jar does not exist
      java.io.FileNotFoundException: E:\gf0914\glassfish3\glassfish\lib\install\applications__admingui\WEB-INF\extra\commons-io-1.3.1.jar (指定されたファイルが見つかりません。)
      at java.util.zip.ZipFile.open(Native Method)
      at java.util.zip.ZipFile.<init>(ZipFile.java:127)
      at java.util.jar.JarFile.<init>(JarFile.java:135)
      at java.util.jar.JarFile.<init>(JarFile.java:72)
      at sun.net.www.protocol.jar.URLJarFile.<init>(URLJarFile.java:72)
      at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:48)
      at sun.net.www.protocol.jar.JarFileFactory.get(JarFileFactory.java:80)
      at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:104)
      at sun.net.www.protocol.jar.JarURLConnection.getJarFile(JarURLConnection.java:71)
      at org.apache.jasper.runtime.TldScanner.scanJar(TldScanner.java:442)
      at org.apache.jasper.runtime.TldScanner.scanJars(TldScanner.java:694)
      at org.apache.jasper.runtime.TldScanner.scanTlds(TldScanner.java:350)
      at org.apache.jasper.runtime.TldScanner.onStartup(TldScanner.java:239)
      at org.apache.catalina.core.StandardContext.callServletContainerInitializers(StandardContext.java:5594)
      at com.sun.enterprise.web.WebModule.callServletContainerInitializers(WebModule.java:595)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:5491)
      at com.sun.enterprise.web.WebModule.start(WebModule.java:512)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:932)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:916)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:687)
      at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:2289)
      at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1935)
      at com.sun.enterprise.web.WebApplication.start(WebApplication.java:109)
      at org.glassfish.internal.data.EngineRef.start(EngineRef.java:122)
      at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:278)
      at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:299)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:497)
      at com.sun.enterprise.v3.server.ApplicationLoaderService.processApplication(ApplicationLoaderService.java:398)
      at com.sun.enterprise.v3.admin.adapter.InstallerThread.load(InstallerThread.java:201)
      at com.sun.enterprise.v3.admin.adapter.InstallerThread.run(InstallerThread.java:98)

      #]

        Activity

        TangYong added a comment -

        Fistly, please confirm whether the problem can be reproduced or not?

        Secondly, on my env, I have found that on glassfish3\glassfish\lib\install\applications__admingui\WEB-INF\extra,
        commons-io-1.1.jar exist and commons-io-1.3.1.jar does not exist. In addition, on the newest gf souce,

        on main\appserver\admingui\war\src\main\webapp\WEB-INF\sun-web.xml, the following code uses commons-io-1.3.1.jar

        <class-loader delegate="true" extra-class-path="WEB-INF/extra/webui-jsf-suntheme-4.0.2.10.jar:WEB-INF/extra/dojo-ajax-nodemo-0.4.1.jar:WEB-INF/extra/webui-jsf-4.0.2.10.jar:WEB-INF/extra/commons-fileupload-1.1.1.jar:WEB-INF/extra/commons-io-1.3.1.jar:WEB-INF/extra/json-1.0.jar:WEB-INF/extra/prototype-1.5.0.jar" />

        So, I think that some place uses commons-io-1.1.jar and other place uses commons-io-1.3.1.jar so that there is some inconsistence on admin gui distribution.

        TangYong added a comment -

        I have found the reason of problem:

        on main\nucleus\pom.xml, the following dependency has been commented out,

        <dependency>
        <groupId>commons-io</groupId>
        <artifactId>commons-io</artifactId>
        <version>1.3.1</version>
        </dependency>

        I did not know the reason of commenting out, however, once uncommenting the above code, the problem will be fixed.

        So, please confirm the nucleus\pom.xml.

        Romain Grécourt added a comment -
        Project:    glassfish
        Repository: svn
        Revision:   55971
        Author:     romain_grecourt
        Date:       2012-09-14 14:47:59 UTC
        Link:       
        
        Log Message:
        ------------
        fix for http://java.net/jira/browse/GLASSFISH-19074. also removing some maven API dependencies...
        
        
        Revisions:
        ----------
        55971
        
        
        Modified Paths:
        ---------------
        trunk/main/nucleus/pom.xml
        
        
        Diffs:
        ------
        Index: trunk/main/nucleus/pom.xml
        ===================================================================
        --- trunk/main/nucleus/pom.xml	(revision 55970)
        +++ trunk/main/nucleus/pom.xml	(revision 55971)
        @@ -1039,43 +1039,12 @@
                         <artifactId>jmockit</artifactId>
                         <version>0.999.15</version>
                     </dependency>
        -<!--            <dependency>
        -                <groupId>org.apache.maven</groupId>
        -                <artifactId>maven-core</artifactId>
        -                <version>2.0.7</version>
        -            </dependency>
                     <dependency>
                         <groupId>commons-io</groupId>
                         <artifactId>commons-io</artifactId>
                         <version>1.3.1</version>
                     </dependency>
                     <dependency>
        -                <groupId>org.apache.maven</groupId>
        -                <artifactId>maven-plugin-api</artifactId>
        -                <version>2.0</version>
        -            </dependency>
        -            <dependency>
        -                <groupId>org.apache.maven.scm</groupId>
        -                <artifactId>maven-scm-api</artifactId>
        -                <version>1.0-beta-3</version>
        -            </dependency>
        -            <dependency>
        -                <groupId>org.apache.maven.plugins</groupId>
        -                <artifactId>maven-scm-plugin</artifactId>
        -                <version>1.0-beta-3</version>
        -            </dependency>
        -            <dependency>
        -                <groupId>org.apache.maven</groupId>
        -                <artifactId>maven-project</artifactId>
        -                <version>2.0</version>
        -            </dependency>
        -            <dependency>
        -                <groupId>org.apache.maven</groupId>
        -                <artifactId>maven-archiver</artifactId>
        -                <version>2.0</version>
        -            </dependency>-->
        -            
        -            <dependency>
                         <groupId>org.apache.ant</groupId>
                         <artifactId>ant</artifactId>
                         <version>1.8.2</version>
        
        
        
        
        

        Please re-open as needed if you still see this issue.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            TangYong
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: