glassfish
  1. glassfish
  2. GLASSFISH-19088

deployment fails for EJB based ws provider implementation class in web project

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.1
    • Fix Version/s: 4.0_b58
    • Component/s: web_services
    • Labels:
      None

      Description

      -have a javaee6 web app with EJB based ws provider implementation
      -deploy such webapp

      =>
      SEVERE: com.sun.enterprise.deployment.annotation.context.WebBundleContext cannot be cast to com.sun.enterprise.deployment.annotation.context.EjbContext
      SEVERE: Exception while deploying the app [WebApplication1]
      SEVERE: com.sun.enterprise.deployment.annotation.context.WebBundleContext cannot be cast to com.sun.enterprise.deployment.annotation.context.EjbContextat org.glassfish.apf.AnnotationInfo@3f4f1a07
      java.lang.IllegalStateException: com.sun.enterprise.deployment.annotation.context.WebBundleContext cannot be cast to com.sun.enterprise.deployment.annotation.context.EjbContextat org.glassfish.apf.AnnotationInfo@3f4f1a07
      at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:505)
      at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:447)
      ...
      Caused by: java.lang.ClassCastException: com.sun.enterprise.deployment.annotation.context.WebBundleContext cannot be cast to com.sun.enterprise.deployment.annotation.context.EjbContext
      at org.glassfish.webservices.connector.annotation.handlers.WebServiceProviderHandler.processAnnotation(WebServiceProviderHandler.java:143)
      at com.sun.enterprise.deployment.annotation.factory.SJSASFactory$1.processAnnotation(SJSASFactory.java:113)
      ...

      see also: http://stackoverflow.com/questions/8017549/glassfish-classcastexception-webbundlecontext-and-ejbcontext

        Issue Links

          Activity

          Lukas Jungmann added a comment -

          sample app


            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              Lukas Jungmann
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: