glassfish
  1. glassfish
  2. GLASSFISH-19097

Successful deployment reported on a domain that is not running

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b55
    • Fix Version/s: None
    • Component/s: deployment
    • Labels:
      None

      Description

      Because of the bug, the hudson run http://hudson-sca.us.oracle.com/job/ejb-devtests-trunk/1376/ failed to start the domain:

      startDomainUnix:
      [echo] Starting DAS
      [exec] com.sun.enterprise.universal.xml.MiniXmlParserException: "Xml Parser Error: java.lang.RuntimeException: "xml error. No closing element for domain found (</domain>).
      [exec] Command start-domain failed.
      [echo] run.xml:doing wait for localhost:49640...
      [echo] run.xml:DONE doing wait for localhost:49640...

      But deployment didn't fail after that:

      deploy-common-pe:
      [exec] javax.ws.rs.client.ClientException: java.net.ConnectException: Connection refused
      [echo] Deployment on target server server successful

        Activity

        marina vatkina added a comment -

        closed

        Hong Zhang added a comment -

        Jeremy, thanks for looking into this!
        Marina: as there is no easy way to reproduce this right now, maybe we should close the issue and re-open it when we have a set of steps to reproduce it?

        Jeremy_Lv added a comment -

        Yes, I have tried about this. But the domain doesn't start up and it's failed when I deploy an application. I'm sorry that I can't reproduce it...

        marina vatkina added a comment -

        Did you try to remove the closing </domain> element (the error reported on the failed start-domain)?

        Jeremy_Lv added a comment -

        marina vatkina:

        May be you can add a sleep somewhere so that the DAS can't start fully to simulate the scenario?

        I think it can be. But it is really a big task for me to add a sleep somewhere because I don't know the reason why it can be deployed successfully on a domain that is not started.
        May be you can show me some stacktrace about this scenario?

        marina vatkina added a comment -

        May be you can add a sleep somewhere so that the DAS can't start fully to simulate the scenario?

        Jeremy_Lv added a comment -

        Hong,marina vatkina:
        Hmm... I think it is diffcult for me to simulate some failure... If we can't reproduce it ,I think we can close it marked as can't reproduce and reopen it if anyone can reproduce it.

        marina vatkina added a comment -

        If you check out devtests, ejb devtests are there. 'ant all' will run them. But they are passing now, so you would need to simulate some failure...

        Jeremy_Lv added a comment -

        Hong:
        I can't access url as http://hudson-sca.us.oracle.com/job/ejb-devtests-trunk/1376/, Can you attach the test file to JIRA. I think I should reproduce it before look into this issue.
        Thanks.


          People

          • Assignee:
            Hong Zhang
            Reporter:
            marina vatkina
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: