Issue Details (XML | Word | Printable)

Key: GLASSFISH-19098
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Masoud Kalali
Reporter: Scott Oaks
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

[PERF] Intermittently cannot start new domain

Created: 21/Sep/12 10:49 PM   Updated: 03/Dec/12 11:01 PM   Resolved: 20/Nov/12 06:42 PM
Component/s: admin
Affects Version/s: 4.0_b55
Fix Version/s: 4.0_b63

Time Tracking:
Not Specified

File Attachments: 1. Text File server.log (3 kB) 21/Sep/12 10:49 PM - Scott Oaks
2. File server.log_2012-09-21T15-36-16 (48 kB) 21/Sep/12 10:49 PM - Scott Oaks


Tags: PSRBUG
Participants: Masoud Kalali and Scott Oaks


 Description  « Hide

About 25% of our tests are failing because we are unable to start a domain immediately after creating it.

We execute these two commands in a script:
asadmin create-domain --adminport 4848 test_instance
asadmin start-domain test_instance

The start-domain appears to succeed (it doesn't not produce any error output), but the server is not up. In the server log, it also appears to have started, but then there are exceptions:

[#|2012-09-21T15:34:43.300-0700|INFO|44.0|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=1;_ThreadName=main;|GlassFish Server Open Source Edition 4.0 (55) startup time : Felix (35,390ms), startup services(6,296ms), total(41,686ms)|#]

[#|2012-09-21T15:34:45.259-0700|INFO|44.0|com.sun.enterprise.config.modularity.ConfigModularityUtils|_ThreadID=1;_ThreadName=main;|The provided path is not valid: server[server]
java.lang.IllegalArgumentException: wrong number of arguments
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at com.sun.enterprise.config.modularity.ConfigModularityUtils.getOwner(ConfigModularityUtils.java:330)
And then the server log shows that the server exits.

There must be some race condition here, because if we wait, we can always start the server find (and if we just execute another start-domain command, the server also starts fine). Something that the ConfigModularityUtils needs has not finished being create/installed by the time start-domain returns.

I am attaching the full server.log files (server.log_<timestamp> from the first startup, and server.log from the subsequent startup).



Masoud Kalali added a comment - 22/Sep/12 05:34 AM

Scott, it seems to be caused by config modularity. I wil investigate and get back to you soon.


Masoud Kalali added a comment - 24/Sep/12 06:05 PM

Can you possibly attach the domain.xml of the test server that causes the failure? that is if you are using a custom domain.xml or you are changing something from the defaults.


Masoud Kalali added a comment - 20/Nov/12 06:42 PM

Fixed