glassfish
  1. glassfish
  2. GLASSFISH-19140

[regression] Exception not printed when startup service fails

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b56_ms5
    • Fix Version/s: 4.0_b58
    • Component/s: other
    • Labels:
      None

      Description

      This bug has been introduced sometime during HK2 2.x integration. I noticed only this much information:

      Startup service failed to start SystemDescriptor(
      implementation=com.sun.enterprise.v3.services.impl.GrizzlyService
      contracts=

      {com.sun.enterprise.v3.services.impl.GrizzlyService,org.glassfish.api.container.RequestDispatcher}

      scope=org.glassfish.hk2.runlevel.RunLevel
      qualifiers={}
      descriptorType=CLASS
      metadata=runLevelValue=

      {10}

      rank=0
      loader=org.jvnet.hk2.osgiadapter.OsgiPopulatorPostProcessor$1@d68713
      id=397
      locatorId=0
      identityHashCode=4075103
      reified=true) due to A MultiException has 2 exceptions. They are:
      1. null
      2. Unable to create or inject com.sun.enterprise.v3.services.impl.GrizzlyService

      Where is the exception stack trace and root cause information?

        Activity

        Sanjeeb Sahoo created issue -
        Sanjeeb Sahoo added a comment -

        svn rev #56350

        Sanjeeb Sahoo made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: