glassfish
  1. glassfish
  2. GLASSFISH-19147

IllegalArgumentException was thrown out when excute the set sub-command

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b56_ms5
    • Fix Version/s: 4.0_b58
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Windows XP, Windows 7

      Description

      [Bug Description]
      When excute the set sub-command in multi-mode, IllegalArgumentException
      was thrown out and exit the multi-mode of asadmin command.

      [Operations]
      Open a command and type as ""asadmin"" to enter the multi-mode, then
      execute the set command as follow:

      asadmin>set --help
      Exception in thread ""main"" java.lang.IllegalArgumentException: Null Argument
        at com.sun.enterprise.admin.util.TokenValue.<init>(TokenValue.java:79)
        at com.sun.enterprise.admin.cli.CLICommand.expandManPage(CLICommand.java
        at com.sun.enterprise.admin.cli.CLICommand.checkHelp(CLICommand.java:814
        at com.sun.enterprise.admin.cli.CLICommand.execute(CLICommand.java:286)
        at com.sun.enterprise.admin.cli.remote.RemoteCLICommand.execute(RemoteCL
        at com.sun.enterprise.admin.cli.MultimodeCommand.executeCommands(Multimo
        at com.sun.enterprise.admin.cli.MultimodeCommand.executeCommand(Multimod
        at com.sun.enterprise.admin.cli.CLICommand.execute(CLICommand.java:303)
        at com.sun.enterprise.admin.cli.AsadminMain.executeCommand(AsadminMain.j
        at com.sun.enterprise.admin.cli.AsadminMain.doMain(AsadminMain.java:283)
        at com.sun.enterprise.admin.cli.AsadminMain.main(AsadminMain.java:199))
      

      PS: If type an unknown options of the set command in the multi-mode,
      the usage message was include some words "null".

      asadmin>set --unknown
      Invalid option: --unknown
      Usage: null [null-utility-options] set [-?|--help[=<help(default:false)>]]
      (dotted-attribute-name=value)+
      Command set failed.
      

      [affected versions]
      1 4.0_b56_ms2
      2 gf's trunk until 2012/10/11

        Activity

        zhouronghui added a comment -

        Hi Tom

        I found the bug when test set sub-command in multimode.
        And I think that the bug is caused by the omitting of
        commandName in MultimodeCommand.java.

        I make a patch for this, and I have run QL for this patch.
        Could you please check the patch?
        If the patch is OK, I will commit it.

        Thank you.

        zhouronghui added a comment -

        Tom have reviewed the patch, and it have been committed.
        While the nightly build was published, I will check the patch and
        close this ISSUE.

        zhouronghui added a comment -

        Fixed on the trunk in revision 56448.

        zhouronghui added a comment -

        Fixed on the trunk in revision 55997.


          People

          • Assignee:
            zhouronghui
            Reporter:
            zhouronghui
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: