Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.0_b61
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Windows Vista

      Description

      GlassFish ver: 3.1.2.2 build 5.
      I can reproduce the issue on my Vista PC but non on server Windows Server 2008.

      Create with NetBeans a new EJB Module. Create a Stateless EJB with a persistent timer annotated like this:

      @Schedule(dayOfWeek="Mon-Fri", hour="7", minute="0", second="0")

      Run it on Sunday.
      During deployment, GlassFish will give the following output:
      Informazioni: keepstate is true and will not create new auto timers during deployment.
      Informazioni: Rescheduling missed expiration for periodic timer '17@@1350199439622@@server@@domain1' 'TimedObject = NewSessionBean' 'Application = EJBModule5' 'CREATED' 'PERIODIC' 'Container ID = 88486669793296384' 'Mon Oct 08 07:00:00 CEST 2012' '0' '0 # 0 # 7 # * # * # Mon-Fri # * # null # null # null # true # dailyTask # 0' . Last timer expiration occurred at Sun Oct 14 10:35:31 CEST 2012

      After deployment, the timer is triggered every second.
      The same module, when deployed on the Server, doesn't give those information messages and the timer is not triggered every second, and this is the correct behaviour.

      1. NewSessionBean.java
        0.5 kB
        perissf

        Activity

        perissf added a comment -

        Note that the deployment has been done on Sun Oct 14. The missed expiration (Mon Oct 08 07:00:00) is on last Monday prior to the deployment date.

        marina vatkina added a comment -

        Can you check the locales of your setups? If the locales are different, you might be seeing this bug: http://java.net/jira/browse/GLASSFISH-18804

        perissf added a comment -

        My default locale is it-IT. I agree that might be the cause, together with keepstate option and a missed expiration. Unfortunately I am not able to reproduce the issue anymore (perhaps because it's Monday).

        marina vatkina added a comment -

        That other bug says it's Sunday specific.

        marina vatkina added a comment -

        patched version for using EN locale for all calendars and string conversions

        marina vatkina added a comment -

        Can you try the attached jar (replace the same jar in the modules dir, preserving the original somewhere)? It has the fix for GLASSFISH-18804.

        marina vatkina added a comment -

        Let's close it as a duplicate of GLASSFISH-18804. Please reopen if the fix for GLASSFISH-18804 doesn't solve it.


          People

          • Assignee:
            marina vatkina
            Reporter:
            perissf
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 day
              1d
              Remaining:
              Remaining Estimate - 1 day
              1d
              Logged:
              Time Spent - Not Specified
              Not Specified