glassfish
  1. glassfish
  2. GLASSFISH-19162

Loader_<xxx> directories in generated/jsp application folders are not deleted after server shutdown

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.0_b56_ms5
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Linux

      Description

      This is basically the same issue that was reported in http://java.net/jira/browse/GLASSFISH-11483. It can be duplicated using the test.war file attached in that issue. Though it was flagged as resolved but I'm seeing the same bug occurring again in the latest stable release (3.1.2.2).

        Issue Links

          Activity

          kksineric_hotmail added a comment -

          As a workaround, we added the code below to the "asadmin" batch file, right before 'exec "$JAVA" -jar "$AS_INSTALL_LIB/admin-cli.jar" "$@"'. This will remove the generated folder upon startup.

          if [ "$1" = "start-domain" ]; then
          echo "Removing generated folder..."
          rm -rf ../domains/domain1/generated
          sleep 2
          fi

          luisjotapepe added a comment -

          Hello guys. I am currently using GlassFish Server Open Source Edition 3.1.2.2 (build 5). My problem is that this is already in Prod environment and we just noticed this. It is happening for domain and clusters across all nodes ie: /usr/local/glassfish3/glassfish/nodes/localhost-domain1/<clustername>/generated/jsp/

          What is safe to delete from here? and what not?

          Kindly appreciate your help

          Hong Zhang added a comment -

          The official GlassFish 4.0 release is targeted for Q2 of 2013:
          https://wikis.oracle.com/display/GlassFish/GlassFishV4Schedule

          But you can get the weekly promoted builds here:
          http://dlc.sun.com.edgesuite.net/glassfish/4.0/promoted/

          kksineric_hotmail added a comment -

          Thanks for verifying the issue. Do you have an estimate on when a stable release for Glassfish 4 will be out?

          Hong Zhang added a comment -

          (Accidentally removed the affected version, put it back)

          Hong Zhang added a comment -

          Yes, I was able to reproduce this issue in 3.1.2.2. This seems to be a regression in 3.1.* code base. The classloader (and related directories) was cleaned up at a later stage of the lifecycle, but that stage was not invoked as part of the server shutdown.

          This issue was already fixed in GlassFish 4.0 (the classloader cleanup is now happening as part of the server shutdown).


            People

            • Assignee:
              Hong Zhang
              Reporter:
              kksineric_hotmail
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: