Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: cdi
    • Labels:
      None

      Description

      According to Weld documentation, one should be able to inject the BoundSessionContext using

      @Inject @Bound SessionContext sessionContext;

      This results in the following error using the Weld version included with Glassfish 3.1.2.2:

      org.jboss.weld.exceptions.DeploymentException: WELD-001409 Ambiguous dependencies for type [SessionContext] with qualifiers [@Default] at injection point [[field] @Inject com.smashmeter.service.ContextManager.sessionContext]. Possible dependencies [[org.jboss.weld.bean-meter-Built-in-org.jboss.weld.context.bound.BoundSessionContext, org.jboss.weld.bean-meter-Built-in-org.jboss.weld.context.http.HttpSessionContext]]

      This should not be the case, as the "@Bound" qualifier is specified.

      Furthermore, trying to make any reference to the interface BoundSessionContext which extends SessionContext will result in a ClassNotFoundExeption.

        Activity

        shreedhar_ganapathy added a comment -

        -> CDI team

        tlcksnyder added a comment -

        Duplicate of GLASSFISH-19668


          People

          • Assignee:
            tlcksnyder
            Reporter:
            JSchneider
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: