glassfish
  1. glassfish
  2. GLASSFISH-19255

Error in formatting Logrecord in jpa tests

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b60
    • Fix Version/s: 4.0_b61
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      RHL 5.0 and JDK1.7.0_03

      Description

      glassfish-4.0-b61-10_28_2012.zip

      During the failure analysis of other jpa issue, I
      noticed that some jpa tests passed with log exception on das so
      that some part of FINE log is not shown, e.g.

      appserver-sqe/pe/ejb/jpa20/ear/bvauto
      http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-das-dbg/134/console
      [echo] - JPA2-BVAuto-EAR-J2DB:persistWithLongName: PASS -
      http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-das-dbg/134/artifact/server.log
      EclipseLink, version: Eclipse Persistence Services - 2.5.0.v20121016-ab08992
      ....
      [#|2012-10-29T11:09:53.293-0700|SEVERE|44.0|javax.enterprise.logging.stderr|
      _ThreadID=93;_ThreadName=p: thread-pool-1; w: 5;_TimeMillis=1351534193293;
      _LevelValue=1000;|java.util.logging.ErrorManager:
      5: Error in formatting Logrecord|#]

      [#|2012-10-29T11:09:53.295-0700|SEVERE|44.0|javax.enterprise.logging.stderr|
      _ThreadID=93;_ThreadName=p: thread-pool-1; w: 5;
      _TimeMillis=1351534193295;_LevelValue=1000;|
      java.lang.NullPointerException
      at java.util.Hashtable.put(Hashtable.java:432)
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.uniformLogFormat(UniformLogFormatter.java:311)
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.format(UniformLogFormatter.java:160)
      at java.util.logging.StreamHandler.publish(StreamHandler.java:196)
      at java.util.logging.ConsoleHandler.publish(ConsoleHandler.java:105)
      at java.util.logging.Logger.log(Logger.java:522)
      at
      org.eclipse.persistence.logging.JavaLog.internalLog(JavaLog.java:290)

      This error is not shown on glassfish-4.0-b60.zip, while FINE log is shown
      http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-das-dbg/135/artifact/server.log
      EclipseLink, version: Eclipse Persistence Services - 2.5.0.v20121016-ab08992
      .....
      [#|2012-10-29T12:10:47.843-0700|FINE|44.0|org.eclipse.persistence.session.file:
      /export/hudson/workspace/sherry-das-dbg/glassfish3/glassfish/domains/domain1/
      applications/jpa20-bvautoApp/lib/entity.jar_pu1.sql|
      ThreadID=88;_ThreadName=p: thread-pool-1; w: 5;
      TimeMillis=1351537847843;_LevelValue=500;ClassName=null;MethodName=null;|
      INSERT INTO BV_EMPL (ID, NAME, SALARY) VALUES (?, ?, ?)
      bind => [3 parameters bound]|#]

        Activity

        Hide
        sherryshen added a comment -

        Raised to P2 since bvauto suite is hanging during cluster run.

        The deploy went through, but it failed to insert entity
        http://sqe-hudson.us.oracle.com:8080/hudson/job/sherry-lc-np/89/
        [exec] asadmin --host localhost --port 4848 --user admin --passwordfile /export/hudson/workspace/sherry-lc-np/appserver-sqe/build-config/adminpassword.txt
        --interactive=false --echo=true --terse=false deploy --force=false --precompilejsp=false --verify=false
        --retrieve /export/hudson/workspace/sherry-lc-np/appserver-sqe/build/ee/amd64_apg-sqe1_Linux/jpa20-bvauto/archive
        --generatermistubs=false --availabilityenabled=false --asyncreplication=true --target sqe-cluster --keepreposdir=false --keepfailedstubs=false
        --isredeploy=false --logreportederrors=true --_classicstyle=false
        /export/hudson/workspace/sherry-lc-np/appserver-sqe/build/ee/amd64_apg-sqe1_Linux/jpa20-bvauto/archive/jpa20-bvautoApp.ear
        [exec] Application deployed with name jpa20-bvautoApp.
        [exec] Command deploy executed successfully.

        [echo] Executing appclient at /export/hudson/workspace/sherry-lc-np/appserver-sqe/pe/ejb/jpa20/ear/bvauto
        ..... hanging

        The similar log error is shown in server.log.
        http://javaweb.us.oracle.com/net/asqe-logs/export1/4.0/Results/build60/core/b19225/lc/server_in2.log

        Show
        sherryshen added a comment - Raised to P2 since bvauto suite is hanging during cluster run. The deploy went through, but it failed to insert entity http://sqe-hudson.us.oracle.com:8080/hudson/job/sherry-lc-np/89/ [exec] asadmin --host localhost --port 4848 --user admin --passwordfile /export/hudson/workspace/sherry-lc-np/appserver-sqe/build-config/adminpassword.txt --interactive=false --echo=true --terse=false deploy --force=false --precompilejsp=false --verify=false --retrieve /export/hudson/workspace/sherry-lc-np/appserver-sqe/build/ee/amd64_apg-sqe1_Linux/jpa20-bvauto/archive --generatermistubs=false --availabilityenabled=false --asyncreplication=true --target sqe-cluster --keepreposdir=false --keepfailedstubs=false --isredeploy=false --logreportederrors=true --_classicstyle=false /export/hudson/workspace/sherry-lc-np/appserver-sqe/build/ee/amd64_apg-sqe1_Linux/jpa20-bvauto/archive/jpa20-bvautoApp.ear [exec] Application deployed with name jpa20-bvautoApp. [exec] Command deploy executed successfully. [echo] Executing appclient at /export/hudson/workspace/sherry-lc-np/appserver-sqe/pe/ejb/jpa20/ear/bvauto ..... hanging The similar log error is shown in server.log. http://javaweb.us.oracle.com/net/asqe-logs/export1/4.0/Results/build60/core/b19225/lc/server_in2.log
        Hide
        sherryshen added a comment -

        To run jpa tests, please see instruction section 5.
        http://aseng-wiki.us.oracle.com/asengwiki/display/ASQA/4.0+Core+Test+Instructions

        To run bvauto suite only, do "ant all" for das or
        "ant ee all" for cluster in test dir.
        Please see my hudson configure as example.
        http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-das-dbg/
        http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-lc-np/

        Show
        sherryshen added a comment - To run jpa tests, please see instruction section 5. http://aseng-wiki.us.oracle.com/asengwiki/display/ASQA/4.0+Core+Test+Instructions To run bvauto suite only, do "ant all" for das or "ant ee all" for cluster in test dir. Please see my hudson configure as example. http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-das-dbg/ http://sqe-hudson.us.oracle.com:8080/hudson/view/Sherry_core/job/sherry-lc-np/
        Hide
        sandeep.shrivastava added a comment -

        This should be fixed with revision 56805.

        Show
        sandeep.shrivastava added a comment - This should be fixed with revision 56805.
        Hide
        sherryshen added a comment -

        Verified the fix on glassfish-4.0-b61.zip.
        EclipsLink FINE log is shown in das run.
        Test is not hanging on cluster run.
        Thanks Sandeep for the prompt fix and support.

        Show
        sherryshen added a comment - Verified the fix on glassfish-4.0-b61.zip. EclipsLink FINE log is shown in das run. Test is not hanging on cluster run. Thanks Sandeep for the prompt fix and support.

          People

          • Assignee:
            sandeep.shrivastava
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: