Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b60
    • Fix Version/s: 4.0_b68_EE7MS3
    • Component/s: jms
    • Labels:
      None

      Description

      Use case 1
      An application contains a session bean and a MDB. The MDB uses the "@MessageDriven(mappedName=" annotation to specify the JNDI name of the destination. This destination resource is defined using a @JMSDestinationDefinition annotation in the session bean. When the application is deployed, deployment of the MDB fails because the resource does not exist.

      Use case 2
      An application contains a MDB only. The MDB uses the "@MessageDriven(mappedName=" annotation to specify the JNDI name of the destination. This destination resource is defined using a @JMSDestinationDefinition annotation in the MDB.
      When the application is deployed, deployment of the MDB fails because the resource does not exist.

      Following exception occured when deploy the MDB, detailed exception stack can see the attached server.log
      com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: JMS resource not created : java:global/jms/myInboundQueue

      Can the resources defined in an application be deployed before MDB deployment?

      Attachment list:
      MDBApp.ear the reproducer application,
      MessageBean.java MDB source code
      server.log GF server log

      1. MessageBean.java
        0.9 kB
        Simon Meng
      2. server.log
        72 kB
        Simon Meng

        Activity

        Hong Zhang added a comment -

        As this is a JMS specific issue (per Jagadish' comments from the email discussions), ressign to Simon to drive the fix for this issue. The deployment team will work with the JMS team to provide any necessary APIs from the deployment side.

        Simon Meng added a comment -

        Fixed at revision 57591.


          People

          • Assignee:
            Simon Meng
            Reporter:
            Simon Meng
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: