glassfish
  1. glassfish
  2. GLASSFISH-19277

validate-multicast command is part of incorrect module

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b60
    • Fix Version/s: 4.0_b64_EE7MS2
    • Component/s: admin
    • Labels:
      None

      Description

      This command which is a cluster/multi-instance related command is currently part of admin-cli.jar.

        Activity

        Tom Mueller added a comment - - edited

        Joe, we need to have this fixed for an upcoming release. Can you get to this in the next couple of weeks? If not, please let me know. Thanks.

        I would recommend moving this command to the cluster-cli.jar module (nucleus/cluster/cli).

        Joe Fialli added a comment -

        Evaluating.

        Joe Fialli added a comment - - edited

        ValidateMulticastCommand.java is not located in admin-cli.jar, it is in gms-adapter.jar.
        Here is listing:

        % jar tvf gms-adapter.jar
        <deleted>
        5575 Tue Nov 22 15:25:26 EST 2011 org/glassfish/gms/admin/validate-multicast.1
        2427 Mon Oct 29 08:15:02 EDT 2012 org/glassfish/gms/admin/ValidateMulticastCommand.class
        <deleted>

        The source code lives in all/main/nucleus/cluster/gms-adapter/src/main/java/org/glassfish/gms/admin/ValidateMulticastCommand.java

        Given that this CLI command is a wrapper around code from shoal-gms-impl.jar that implement validate multicast,
        I believe this is a reasonable location for the code. If no one objects, I recommend closing this issue as not a bug.

        Tom Mueller added a comment -

        Sorry for the mistake about this being in admin-cli.jar.

        The problem is that validate-multicast is showing up in the list-commands output for a skinned command that is not "asadmin". The reason for this is that gms-adapter.jar is included the classpath for admin-cli.jar in the pom.xml file.

        The problem with gms-adapter.jar is that includes code that runs in the server as well as this local command which runs in the asadmin command. Local commands should be separated out into their own JAR file. cluster-cli.jar is one of those JAR files (it now resides in lib/asadmin rather than in modules). A similar solution is needed for validate-multicast.

        Joe Fialli added a comment -

        Outstanding documentation subtask:

        After moving ValidateMulticastCommand.java from nucleus/cluster/gms-adapter to nucleus/cluster/cli,
        it was noted that validate-multicast.1 man page needs to be moved from artifactid cluster-gms-adapter-manpage to cluster-cli-manpage. Additionally the package name changed from org.glassfish.gms.admin to com.sun.enterprise.admin.cli.cluster. (the man page file name incorporates the package name of the command.)

        Joe Fialli added a comment -

        The engineering part of task is completed and checked in. Only the documentation subtask is outstanding.

        Joe Fialli added a comment -

        Only the doc subtask is outstanding. This fix has already been checked in.


          People

          • Assignee:
            Joe Fialli
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: