glassfish
  1. glassfish
  2. GLASSFISH-19295

Admin console not running on OpenJDK on Debian 6 ("Sequeeze")

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Invalid
    • Affects Version/s: 3.1.2.2
    • Fix Version/s: None
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      686 / Debian 6 ("Squeeze") / OpenJDK 1.6.0_18

      Description

      The admin console is not booting on Debian 6 ("Squeeze") using OpenJDK 1.6.0_18:

      java.lang.UnsupportedOperationException: Cannot create XMLStreamReader or XMLEventReader from a
      javax.xml.transform.stream.StreamSource
      at com.sun.xml.internal.stream.XMLInputFactoryImpl.jaxpSourcetoXMLInputSource(XMLInputFactoryImpl.java:283)
      at com.sun.xml.internal.stream.XMLInputFactoryImpl.createXMLStreamReader(XMLInputFactoryImpl.java:143)
      at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:109)
      at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:104)
      at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:100)
      at org.glassfish.admingui.plugin.ConsolePluginService.init(ConsolePluginService.java:121)
      at org.glassfish.admingui.plugin.ConsolePluginService.getIntegrationPoints(ConsolePluginService.java:423)
      at org.glassfish.admingui.common.handlers.PluginHandlers.getIntegrationPoints(PluginHandlers.java:160)
      at org.glassfish.admingui.handlers.ThemeHandlers.getThemeFromIntegrationPoints(ThemeHandlers.java:98)
      ... 47 more

      As OpenJDK is the official open source JRE provided by Oracle, one would expect that GlassFish does not need anything that is not contained in OpenJDK. This is a blocker for all pure-open-source users, as the OracleJDK is runing well but is neither open nor free.

        Activity

        Hide
        Anissa Lam added a comment -

        >> Environment: 686 / Debian 6 ("Squeeze") / OpenJDK 1.6.0_18

        Your JDK doesn't meet the minimum requirement.
        3.1.1 and/or 3.1.2 requires JDK 1.6.0_26+

        You can check the GlassFish Server 3.1.1 Certification Matrix in the Release Note.
        http://docs.oracle.com/cd/E18930_01/html/821-2434/abpaj.html#abpak

        closing as invalid.

        Show
        Anissa Lam added a comment - >> Environment: 686 / Debian 6 ("Squeeze") / OpenJDK 1.6.0_18 Your JDK doesn't meet the minimum requirement. 3.1.1 and/or 3.1.2 requires JDK 1.6.0_26+ You can check the GlassFish Server 3.1.1 Certification Matrix in the Release Note. http://docs.oracle.com/cd/E18930_01/html/821-2434/abpaj.html#abpak closing as invalid.
        Hide
        shreedhar_ganapathy added a comment -

        Reassigning to Anissa to take a look.

        Show
        shreedhar_ganapathy added a comment - Reassigning to Anissa to take a look.
        Hide
        Anissa Lam added a comment -

        Move to hk2 for initial investigation as the stack trace shows that the exception comes from ConfigParser.

        Show
        Anissa Lam added a comment - Move to hk2 for initial investigation as the stack trace shows that the exception comes from ConfigParser.

          People

          • Assignee:
            Anissa Lam
            Reporter:
            mkarg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: