Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b62_ms6
    • Fix Version/s: 4.0_b63
    • Component/s: jax-rs
    • Labels:
      None
    • Environment:

      REL 5 and JDK1.7.0_03

      Description

      JAXRS failure with Default JAXBContext

      glassfish-4.0-b62.zip
      appserver-sqe/pe/ejb/moxy/jaxrs3
      e.g.
      Failed to get data from jaxrs, e.g.
      [java] Got Ex
      [java] java.io.FileNotFoundException: http://localhost:8080/jaxrs3-jaxbri/rest/customers/1

      The same test passed on glassfish-4.0-b61.zip

      The client output is similar to previous failure on b49
      http://java.net/jira/browse/GLASSFISH-18813
      which provided test steps.

        Activity

        sherryshen added a comment -

        Verified the fix on glassfish-4.0-b63.zip

        From the email discussion,
        [1] The root cause is a regression in Jersey.
        http://java.net/jira/browse/JERSEY-1579

        [2] The problem is introduced with
        Jersey version upgrade 2.0-m09->2.0-m09-1 on Nov. 1, 2012 in b62.

        [3] Jersery 2.0-m09-1 is reverted in b63.

        [4] From Jason, admin dev tests reported the failure,
        main/nucleus/tests/admin.
        Will update QL tests to exercise GET, POST, and DELETE so that
        we can, hopefully, catch this kind of thing more quickly.

        [5] Jason committed a change to the QL tests that
        should catch that kind of thing in the future.

        [6] Jakub set up 3 more hudson jobs to test Jersey snapshot with GF4 trunk.
        http://sysifos-sol.cz.oracle.com/hudson/view/Jersey%202/view/GF%20Integration/


          People

          • Assignee:
            Jakub Podlesak
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: