Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_dev
    • Component/s: packaging
    • Labels:
      None

      Issue Links

        Activity

        Romain Grécourt added a comment -

        org.eclipse.persistence:javax.persistence has non UTF-8 characters:
        [ERROR] Exit code: 1 - javax/persistence/EntityManager.java:105: error: unmappable character for encoding UTF-8
        [ERROR] * is not a valid type for that entity?s primary key or
        [ERROR] ^
        [ERROR] javax.javaee-web-api/target/sources-dependency/javax/persistence/EntityManager.java:125: error: unmappable character for encoding UTF-8
        [ERROR] * is not a valid type for that entity?s primary key or
        [ERROR] ^
        [ERROR] javax/persistence/MapsId.java:74: error: unmappable character for encoding UTF-8
        [ERROR] * supplied, the relationship maps the entity?s primary
        [ERROR] ^

        Romain Grécourt added a comment -

        We are currently using org.eclipse.persistence:javax.persistence:2.0.105.v201212201717, but it has some UTF8 issues in the source bundle (javax/persistence/EntityManager.java @line 104).
        I've just tried http://download.eclipse.org/rt/eclipselink/maven.repo/org/eclipse/persistence/javax.persistence/2.0.5/javax.persistence-2.0.5-sources.jar and verified the problem is still there !

        Romain Grécourt added a comment -

        David integrated eclipselink 2.1.0-M7 last week.
        The UTF8 issue has been fixed, the JavaEE bundles will include JPA 2.1 as of b75


          People

          • Assignee:
            Romain Grécourt
            Reporter:
            Romain Grécourt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 week
              1w
              Remaining:
              Remaining Estimate - 1 week
              1w
              Logged:
              Time Spent - Not Specified
              Not Specified