Issue Details (XML | Word | Printable)

Key: GLASSFISH-19415
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: Jason Lee
Reporter: Anissa Lam
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

Response content length is set zero , causing many pages failure in admin console

Created: 06/Dec/12 08:40 PM   Updated: 11/Dec/12 03:59 PM   Resolved: 11/Dec/12 03:59 PM
Component/s: rest-interface
Affects Version/s: 4.0_b66
Fix Version/s: 4.0_b67_ms7

Time Tracking:
Not Specified

Tags:
Participants: Anissa Lam and Jason Lee


 Description  « Hide

Many of the console pages has stopped working due to the missing information from the Response.
This error has been there for quite a while, and reproducible in latest build.

Here is what I am seeing. Notice that Content-Length is set to zero.
The command actually goes through fine, domain.xml get updated correctly. However, the response it sent back is missing info.

Also please confirm if the returned 201 status is what it suppose to be. It is setting some attribute, nothing should be 'created'.

~ 2) curl -s -S --user admin: -H 'Accept: application/json' -H 'X-Requested-By: foo' -X POST -vsS -d 'applicationRoot=${com.sun.aas.instanceRoot}/applications' -d locale=null -d 'logRoot=${com.sun.aas.instanceRoot}/ABClog' -d version=anilam-private http://localhost:4848/management/domain

  • About to connect() to localhost port 4848 (#0)
  • Trying ::1... connected
  • Connected to localhost (::1) port 4848 (#0)
  • Server auth using Basic with user 'admin'
    > POST /management/domain HTTP/1.1
    > Authorization: Basic YWRtaW46
    > User-Agent: curl/7.21.4 (universal-apple-darwin11.0) libcurl/7.21.4 OpenSSL/0.9.8r zlib/1.2.5
    > Host: localhost:4848
    > Accept: application/json
    > X-Requested-By: foo
    > Content-Length: 134
    > Content-Type: application/x-www-form-urlencoded
    >
    < HTTP/1.1 201 Created
    < Date: Thu, 06 Dec 2012 20:11:10 GMT
    < Content-Length: 0 <============================== BUG
    <
  • Connection #0 to host localhost left intact
  • Closing connection #0


Anissa Lam added a comment - 11/Dec/12 03:59 PM

Jason has checked in a fix and i verified that it is working as before. Console back to normal now.