glassfish
  1. glassfish
  2. GLASSFISH-19418

Memory leak with Simple Tag Handler and CDI enabled

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.0
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      Windows7 64bit with jdk7_u3, linux with jdk6, Glassifish Open Source 3.1.2

      Description

      When CDI is enabled on a web application which uses JSP tag files instances of tag files remain inside com.sun.enterprise.container.common.impl.managedbean.ManagedBeanManagerImpl in jcdiManagedBeanInstanceMap.

      Instances of tag files contains references to JspContext which contains a reference to JspWriterImpl, which contains a buffer which holds response data

      This is a memory leak which leads to OutOfMemoryErrors very quickly

        Activity

        pukkaone added a comment -

        Sorry, this issue was cloned by mistake. Please close it.

        Sivakumar Thyagarajan added a comment -

        Transferring to JJ Snyder

        Sivakumar Thyagarajan added a comment -

        Closing this as a duplicate of GLASSFISH-18650 as requested by the bug submitter.


          People

          • Assignee:
            jjsnyder83
            Reporter:
            pukkaone
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: