glassfish
  1. glassfish
  2. GLASSFISH-19432

asadmin deploy provides a misleading error message

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b72_EE7MS4
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      Reproducible operational steps:
      asadmin.bat deploy axws-w2j-02-web.war

      Detailed description of the issue:
      When a war file is deployed by asadmin deploy command, it provided a misleading error message.
      asadmin.bat deploy C:\Projects\TRAC\4851\jaxws-w2j-02-web.war
      remote failure: Error occurred during deployment: Exception while preparing the
      app : Service AddNumbersService seems to be a JAXRPC based web service but without the mandatory WSDL and Mapping file. Deployment cannot proceed. Please see server.log for more details.
      Command deploy failed.

      In fact, the war file contains valid WSDL and Mapping file although there exist other bugs in the war file.

      The testing was under GlassFish v4 trunk (built from https://svn.java.net/svn/glassfish~svn/trunk (revision 57288))

        Issue Links

          Activity

          Hong Zhang added a comment -

          The error message is from webservices code, assign to webservices team for evaluation.

          Hong Zhang added a comment -

          Assign to webservice team for evaluation as the error message is from the webservices code (when I previously reassigned it I forgot to change the assigned engineer and only changed category).

          Martin Grebac added a comment -

          I see - Lukasi - is this WS issue?

          Lukas Jungmann added a comment - - edited

          yep, this is ours. The real cause is buried in the server side log:

          SEVERE: Unable to load impl class fromwsdl.server.AddNumbersImpl
          java.lang.ClassNotFoundException: fromwsdl.server.AddNumbersImpl
          ...
          	at org.glassfish.webservices.WsUtil.isJAXWSbasedService(WsUtil.java:744)
          	at org.glassfish.webservices.WebServicesDeployer.prepare(WebServicesDeployer.java:166)
          

          this error should be made critical and sent back to the user instead of allowing further processing. In this sense it is duplicate of GLASSFISH-19366.

          The difference between these two issues is the real cause:
          *this issue - servlet-class links to non-existing class
          *GLASSFISH-19366 - servlet-class element is missing


            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              xianwu
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: