glassfish
  1. glassfish
  2. GLASSFISH-19461

All resource adapter tests in JMS CTS fail with InvalidDestinationException: [C4050]: Invalid destination name

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 4.0_b67_ms7
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None
    • Environment:

      N/A

      Description

      The following tests fail in CTS JMS. All resource adapter tests fail to deploy on GlassFish. Get
      exception: Caused by: javax.jms.InvalidDestinationException: [C4050]: Invalid destination name -

      {0}

      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectorauto/annotated/Client.java#negativeTest1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectorauto/annotated/Client.java#negativeTest2
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectorauto/annotated/Client.java#test1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectorauto/descriptor/Client.java#negativeTest1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectorauto/descriptor/Client.java#negativeTest2
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectorauto/descriptor/Client.java#test1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectordups/annotated/Client.java#negativeTest1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectordups/annotated/Client.java#negativeTest2
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectordups/annotated/Client.java#test1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectordups/descriptor/Client.java#negativeTest1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectordups/descriptor/Client.java#negativeTest2
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/queue/selectordups/descriptor/Client.java#test1
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/noselnocltidnosubnamedurable/annotated/Client.jav
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/noselnocltidnosubnamedurable/descriptor/Client.ja
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectorautoclientiddurable/annotated/Client.java
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectorautoclientiddurable/annotated/Client.java
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectorautoclientiddurable/annotated/Client.java
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectorautoclientiddurable/descriptor/Client.jav
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectorautoclientiddurable/descriptor/Client.jav
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectorautoclientiddurable/descriptor/Client.jav
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectordupsnondurable/annotated/Client.java#nega
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectordupsnondurable/annotated/Client.java#nega
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectordupsnondurable/annotated/Client.java#test
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectordupsnondurable/descriptor/Client.java#neg
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectordupsnondurable/descriptor/Client.java#neg
      FAILED........com/sun/ts/tests/jms/ee20/ra/activationconfig/topic/selectordupsnondurable/descriptor/Client.java#tes

        Activity

        Nigel Deakin added a comment -

        This feature is not yet implemented and so this is not a bug.


          People

          • Assignee:
            David Zhao
            Reporter:
            alanf760
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: