glassfish
  1. glassfish
  2. GLASSFISH-19479

JMS Resource -> Destination Resources shows ALL admin object resource, even when its not using jmsra resource adapter

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b68_EE7MS3
    • Fix Version/s: 4.0_b69
    • Component/s: admin_gui
    • Labels:
      None

      Description

      Step to reproduce:

      • deploy the attached rar
      • create an admin object resource named 'ABC' using 'genericra' as the resource adapter
      • ABC will show up under JMS Resource tree node, this is a bug. This is not a JMS resource and list-jms-resources command doesn't show that either.

        Issue Links

          Activity

          Anissa Lam added a comment -

          Changed the code that populates the JMS resources tree node.

          JMS Resources -> Connection Factories is generated by calling
          list-jms-resources --restype javax.jms.ConnectionFactory
          list-jms-resources --restype javax.jms.TopicConnectionFactory
          list-jms-resources --restype javax.jms.QueueConnectionFactory
          and combining the returned list.

          JMS Resources -> Destination Resources is generated by calling
          list-jms-resources --restype javax.jms.Queue
          list-jms-resources --restype javax.jms.Topic
          and combining the returned list.

          However, due to GLASSFISH-19482, those tree nodes maybe wrong. Once GLASSFISH-19482 is fixed, the tree node will be correct.


            People

            • Assignee:
              Anissa Lam
              Reporter:
              Anissa Lam
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: