Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Activity

      sangqiang added a comment -

      when i run the flow command,an error always happens.
      command:
      asadmin --host=$

      {remoteHostName}

      --port=$

      {remotePort}

      list-clusters
      example:asadmin --host=193.168.175.224 --port=12001 list-clusters
      error message:
      HTTP接続がコード403で失敗しました。メッセージ: null
      コマンドlist-clustersが失敗しました。

      sangqiang added a comment -

      sorry,i think this is not a bug.
      when i run the flowing command,remote command can run successfull.
      command: asadmin enable-secure-admin

      but i still wan't to known the diffrernt between in GlassfishV2 and GlassfishV3 about the remote command.
      for example,in glassfishV2,when user run the flowing command,remote command can run succefful.
      command: asadmin $

      {subCommand Name}

      --host=$

      {remoteHostName}

      --port=

      {remoteHostPort}

      ex: asadmin list-clusters --host=193.168.175.224 --port=4949

      but why when user run the same subCommand like glassfishV2,403 error happens?
      why after user run [enable-secure-admin] subcommand,user run remotecommand like glassfishV2 can run successfull?
      can you help me?

      Tim Quinn added a comment -

      Please read this blog:

      https://blogs.oracle.com/quinn/entry/securing_adminstration_in_glassfish_server1

      which explains the reason for the change in behavior.

      The GlassFish Security Guide

      http://docs.oracle.com/cd/E26576_01/doc.312/e24940/toc.htm

      has useful information also.


        People

        • Assignee:
          Tim Quinn
          Reporter:
          sangqiang
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: