Issue Details (XML | Word | Printable)

Key: GLASSFISH-19486
Type: Improvement Improvement
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: Snjezana Sevo-Zenzerovic
Reporter: Mohamed Taman
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

Glassfish 4 installer should detect and require JDK7.

Created: 29/Dec/12 03:38 PM   Updated: 19/Mar/13 08:29 PM   Resolved: 19/Mar/13 08:29 PM
Component/s: installation
Affects Version/s: 4.0_b69
Fix Version/s: 4.0_b81

Time Tracking:
Not Specified

Environment:

Windows 7 Professional SP1
Mac OS X v10.6.8


Tags: adoptajsr
Participants: Mohamed Taman, Snjezana Sevo-Zenzerovic and Tom Mueller


 Description  « Hide

I have JDK6(Default) and JDK7 installed on the same machine (Windows and Mac), and when I have unzipped the glassfish_4_b69 and run it for the first time it reports the following exception

*"asadmin> start-domain domain1
Waiting for domain1 to start .............Error starting domain domain1.
The server exited prematurely with exit code 1.
Before it died, it produced the following output:
........
Caused by: A MultiException has 2 exceptions. They are:
1. java.lang.UnsupportedClassVersionError: org/glassfish/jdbc/config/JdbcResourceInjector : Unsupported major.minor version 51.0"
*

After investigation, It should run on JDK7 not JDK6, but the error is misleading somehow, it should be there some sort of detection for the exact version of proper supported JDK, and then reports a proper error message, something like "Unsupported JDK version, use JDK7 version."+

Also

The windows installer detects and show the jdk6 even I have JDK 7 installed without warnings, and when I pointed to JDK 7 it give me a warning message the there is no java home selected.



Tom Mueller added a comment - 02/Jan/13 05:37 PM

The version checking in the startup logic has been changed to enforce JDK 7 in revision 57887 on the trunk.


Tom Mueller added a comment - 02/Jan/13 05:39 PM

Reassigning this to the installation component so that the last part (under "Also") can be fixed. Specifically, the installer needs to detect only JDK 7 installs for GF 4. This fix is required for 4.0.


Snjezana Sevo-Zenzerovic added a comment - 19/Mar/13 08:29 PM

JDK 7 specified as the lowest supported version in install wrapper and JDK selection screen.