Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b72_EE7MS4
    • Component/s: jca
    • Labels:
      None

      Description

      Please refer the parent issue GLASSFISH-19480
      It is required to mask the confidential properties when various artifacts like "resource-adapter-config", "connector-connection-pool", "admin-object-resource" etc., are created or updated.
      In order for GUI to support the feature, list of confidential properties must be made available.
      This will be made available through "extraProperties" a protocol used by GUI/REST.

      Following commands will have additional "list" that has the "confidential" property names. GUI can get this list and compare against the config properties and mask the config properties that matches with any of "confidential" property names.

      _get-resource-adapter-config-properties
      key name in "extraProperties" : confidentialConfigProps

      _get-admin-object-config-properties
      key name in "extraProperties" : confidentialConfigProps

      _get-mcf-config-properties
      key name in "extraProperties" : confidentialConfigProps

      _get-message-listener-config-properties
      key name in "extraProperties" : confidentialConfigProps

        Activity

        Jagadish added a comment -

        FIX INFORMATION :
        svn log -v -r 58255
        ------------------------------------------------------------------------
        r58255 | jr158900 | 2013-01-10 09:08:39 +0530 (Thu, 10 Jan 2013) | 5 lines
        Changed paths:
        M /trunk/main/appserver/connectors/admin/src/main/java/org/glassfish/connectors/admin/cli/internal/GetAdminObjectConfigProps.java
        M /trunk/main/appserver/connectors/admin/src/main/java/org/glassfish/connectors/admin/cli/internal/GetMCFConfigProperties.java
        M /trunk/main/appserver/connectors/admin/src/main/java/org/glassfish/connectors/admin/cli/internal/GetMessageListenerConfigProperties.java
        M /trunk/main/appserver/connectors/admin/src/main/java/org/glassfish/connectors/admin/cli/internal/GetResourceAdapterConfigProperties.java
        M /trunk/main/appserver/connectors/connectors-internal-api/src/main/java/com/sun/appserv/connectors/internal/api/ConnectorConstants.java
        M /trunk/main/appserver/connectors/connectors-internal-api/src/main/java/com/sun/appserv/connectors/internal/api/ConnectorRuntime.java
        M /trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/ConnectorRuntime.java
        M /trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/util/AdminObjectConfigParserImpl.java
        M /trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/util/ConnectorConfigParser.java
        M /trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/util/MCFConfigParserImpl.java
        M /trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/util/MessageListenerConfigParserImpl.java
        M /trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/util/ResourceAdapterConfigParserImpl.java
        M /trunk/main/appserver/deployment/dol/src/main/java/com/sun/enterprise/deployment/AdminObject.java

        Anissa Lam added a comment -

        With the latest build, rev# 58310, the following 2 hidden commands:
        _get-admin-object-config-properties and
        _get-resource-adapter-config
        always gives error.

        Here is what is returned:

        %asadmin _get-admin-object-config-properties --adminObjectInterface connector.MyAdminObject --adminObjectClass connector.MyAdminObject --rarName generic-ra

        remote failure: _get-admin-object-config-properties failed : Invalid type : AdminObjectResource
        Invalid type : AdminObjectResource
        Command _get-admin-object-config-properties failed.

        ==================

        %asadmin _get-resource-adapter-config-properties --rarName jmsra
        remote failure: _get-resource-adapter-config-properties failed : Invalid type : jmsra
        Invalid type : jmsra
        Command _get-resource-adapter-config-properties failed.
        ==================

        Due to these error, the current console is broken on the Resource Adapter Configuration and Admin Object Resource screen.

        Anissa Lam added a comment -

        The above reported issue has bee fixed now.

        However, I notice that for _get-resource-adpater-config-properties, it doesn't return the properties from domain.xml, instead, it always return the 'original' value.
        To reproduce:

        • create jmsra resource adapter config with Property "UserName" set to "guest123".
        • The resource adapter config is created with UserName "guest123"
        • now call _get-resource-config-properties of this, you can see that it still returns "guest" as the UserName even though domain.xml has "guest123".

        I haven't tried other hidden command to see if it's behaving that way.

        Anissa Lam added a comment -

        I have opened GLASSFISH-19534 for _get-resource-adapter-config-properties. I am closing this as resolved.


          People

          • Assignee:
            Jagadish
            Reporter:
            Jagadish
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: