glassfish
  1. glassfish
  2. GLASSFISH-19572

Simplify exporting of com.sun.ejb.containers.interceptors from ejb-container

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b68_EE7MS3
    • Fix Version/s: future release
    • Component/s: cdi
    • Labels:
      None

      Description

      A CDI tck test was failing because ejb interceptors not visible to cdi module. I exported the entire com.sun.ejb.containers.interceptors package but it may not be necessary to export the entire package.

        Activity

        jjsnyder83 created issue -
        jjsnyder83 added a comment -

        Committed revision 58766

        jjsnyder83 made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        jjsnyder83 added a comment -

        Find the tck test that fails so that we can investigate further. We might want to add an interface or move things around. It's not the best choice to export the whole package at once.

        jjsnyder83 made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        jjsnyder83 made changes -
        Component/s cdi [ 10637 ]
        Component/s ejb_container [ 10596 ]
        tlcksnyder made changes -
        Fix Version/s 4.0 [ 10970 ]
        jjsnyder83 made changes -
        Fix Version/s future release [ 11148 ]
        Fix Version/s 4.0 [ 10970 ]
        jjsnyder83 made changes -
        Summary cdi tck test failing because ejb interceptors not visible to cdi module Simplify exporting of com.sun.ejb.containers.interceptors from ejb-container
        Description The com.sun.ejb.containers.interceptors package is not exported and hence cdi is not picking up ejb interceptors and failing cdi tck tests. A CDI tck test was failing because ejb interceptors not visible to cdi module. I exported the entire com.sun.ejb.containers.interceptors package but it may not be necessary to export the entire package.
        jjsnyder83 made changes -
        Assignee jjsnyder83 [ jjsnyder83 ] phil.zampino [ phil.zampino ]
        phil.zampino added a comment -

        I tried removing the export that was added via rev. 58766, but I can't reproduce any CDI TCK failures with this change.

        phil.zampino made changes -
        Status Reopened [ 4 ] In Progress [ 3 ]
        phil.zampino added a comment -

        Committed rev. 62498

        phil.zampino made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        phil.zampino made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            phil.zampino
            Reporter:
            jjsnyder83
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: