Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b70
    • Fix Version/s: 4.0_b71
    • Component/s: OSGi
    • Labels:
      None

      Description

      We should upgrade to Felix 4.0.3 from 4.0.2.

      It requires running various tests.

        Activity

        TangYong added a comment - - edited

        1 [Result] Run test against web profile using felix 4.0.3 and felix 4.0.2

        The two versions's results are the same while creating a new domain seperately.

        ===============================================
        QuickLookTests
        Total tests run: 90, Failures: 8, Skips: 0
        ===============================================

        Among failed tests, rest related tests still failed!
        So, if previously being successful, I think that recently there are some commits which cause regression.

        I will re-create a new domain for full profile tests. Please wait.

        TangYong added a comment -

        2 [Result] Run test against full profile using felix 4.0.3 and felix 4.0.2

        The two versions's results are the same too while creating a new domain seperately.

        ===============================================
        QuickLookTests
        Total tests run: 112, Failures: 8, Skips: 0
        ===============================================

        Among failed tests, rest related tests still failed!

        BTW: in oder to see which tests failed clearly, please seeing the following(many related to admin):

        <!DOCTYPE suite SYSTEM "http://testng.org/testng-1.0.dtd">
        <suite thread-count="5" verbose="2" name="Failed suite [QuickLookTests]" junit="false" annotations="JDK">
        <parameter name="MDB_APP_DIR" value="./dist/mdb/"/>
        <parameter name="BATCH_FILE1" value="ejb/mdb/create_resources.asadmin"/>
        <parameter name="BATCH_FILE2" value="ejb/mdb/delete_resources.asadmin"/>
        <parameter name="amx.debug" value="true"/>
        <parameter name="admin.password" value=""/>
        <parameter name="admin.console.url" value="http://localhost:4848/"/>
        <parameter name="amx.rmiport" value="8686"/>
        <parameter name="admin.user" value="admin"/>
        <parameter name="resources.xml.relative.path" value="admin/resources/resources.xml"/>
        <parameter name="admin.url" value="http://localhost:4848/__asadmin"/>
        <test name="adminconsole_tests(failed)" junit="false" annotations="JDK">
        <parameter name="MDB_APP_DIR" value="./dist/mdb/"/>
        <parameter name="BATCH_FILE1" value="ejb/mdb/create_resources.asadmin"/>
        <parameter name="BATCH_FILE2" value="ejb/mdb/delete_resources.asadmin"/>
        <parameter name="amx.debug" value="true"/>
        <parameter name="admin.password" value=""/>
        <parameter name="admin.console.url" value="http://localhost:4848/"/>
        <parameter name="amx.rmiport" value="8686"/>
        <parameter name="admin.user" value="admin"/>
        <parameter name="resources.xml.relative.path" value="admin/resources/resources.xml"/>
        <parameter name="admin.url" value="http://localhost:4848/__asadmin"/>
        <classes>
        <class name="test.admin.AdminConsoleTests">
        <methods>
        <include name="testDeployedAppPage"/>
        <include name="testCommonTasks"/>
        <include name="shutdownClient"/>
        <include name="loginBeforeTest"/>
        <include name="testRealmsList"/>
        </methods>
        </class>
        </classes>
        </test>
        <test name="admincli_tests(failed)" junit="false" annotations="JDK">
        <parameter name="MDB_APP_DIR" value="./dist/mdb/"/>
        <parameter name="BATCH_FILE1" value="ejb/mdb/create_resources.asadmin"/>
        <parameter name="BATCH_FILE2" value="ejb/mdb/delete_resources.asadmin"/>
        <parameter name="amx.debug" value="true"/>
        <parameter name="admin.password" value=""/>
        <parameter name="admin.console.url" value="http://localhost:4848/"/>
        <parameter name="amx.rmiport" value="8686"/>
        <parameter name="admin.user" value="admin"/>
        <parameter name="resources.xml.relative.path" value="admin/resources/resources.xml"/>
        <parameter name="admin.url" value="http://localhost:4848/__asadmin"/>
        <classes>
        <class name="test.admincli.RestartDomainTests">
        <methods>
        <include name="restartDomainTest"/>
        </methods>
        </class>
        </classes>
        </test>
        <test name="rest_tests(failed)" junit="false" annotations="JDK">
        <parameter name="MDB_APP_DIR" value="./dist/mdb/"/>
        <parameter name="BATCH_FILE1" value="ejb/mdb/create_resources.asadmin"/>
        <parameter name="BATCH_FILE2" value="ejb/mdb/delete_resources.asadmin"/>
        <parameter name="amx.debug" value="true"/>
        <parameter name="admin.password" value=""/>
        <parameter name="admin.console.url" value="http://localhost:4848/"/>
        <parameter name="amx.rmiport" value="8686"/>
        <parameter name="admin.user" value="admin"/>
        <parameter name="resources.xml.relative.path" value="admin/resources/resources.xml"/>
        <parameter name="admin.url" value="http://localhost:4848/__asadmin"/>
        <classes>
        <class name="test.admin.RestTests">
        <methods>
        <include name="testManagementEndpoint"/>
        <include name="testEndpointWithEncodedSlash"/>
        <include name="testAdminCommandEndpoint"/>
        <include name="testChildConfigBeanEndpoint"/>
        </methods>
        </class>
        </classes>
        </test>
        </suite>

        TangYong added a comment - - edited

        Conclusion(My opinion):

        1 updating felix 4.0.3 does not cause current trunk's regression.

        2 compared to previous gf, recently maybe some components have caused regression.

        Deeply, if running QL tests on previous gf's version has not any failed test, currently, the following components need to be confirmed whether causing regression.

        1) Admin Rest and Rest Related Modules
        2) Admin Console
        3) Admin CLI
        4) QL Test Cases self

        Thanks.

        Sanjeeb Sahoo added a comment -

        Thanks for verifying that there are no regressions caused by Felix 4.0.3.

        I will integrate your patch ASAP.

        Thanks,
        Sahoo

        Sanjeeb Sahoo added a comment -

        ------------------------------------------------------------------------
        r58813 | ss141213 | 2013-01-26 17:11:43 +0530 (Sat, 26 Jan 2013) | 3 lines

        GLASSFISH-19586: Upgrade to Felix 4.0.3
        Patch provided by Tang Yong.


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: