glassfish
  1. glassfish
  2. GLASSFISH-19613

no glassfish-acc.xml in created domain ogs.zip

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b73
    • Fix Version/s: 4.0_b74
    • Component/s: admin
    • Labels:
      None
    • Environment:

      REL5 and JDK1.7.0_11

      Description

      ogs-4.0-b73-01_31_2013.zip

      In core cluster tests, sqe-domain, and sqe-cluster are crated and started.
      The tests failed with missing glassfish-acc.xml in created sqe-domain.

      The same tests passed on glassfish-4.0-b73_01_31_2013.zip or ogs-4.0-b72_2013.zip

        Activity

        sherryshen added a comment -

        Test failure about missing glassfish-acc.xml

        BUILD FAILED
        /export/hudson/workspace/sherry-lc-dbg/appserver-sqe/build-config/sqe-common.xml:383:
        /export/hudson/workspace/sherry-lc-dbg/glassfish3/glassfish/domains/sqe-domain/config/glassfish-acc.xml
        doesn't exist

        cli.log about create-domain and create-cluster.
        01/31/2013 19:25:24 EXIT: 0 asadmin version --verbose
        01/31/2013 19:25:37 EXIT: 0 asadmin create-domain --adminport 4848 --user admin --nopassword sqe-domain
        01/31/2013 19:25:45 EXIT: 0 asadmin --user admin --passwordfile .....nfig/adminpassword.txt start-domain sqe-domain
        01/31/2013 19:25:47 EXIT: 0 asadmin --user admin --passwordfile .....nfig/adminpassword.txt --echo=false version
        01/31/2013 19:25:54 EXIT: 0 asadmin --user admin --passwordfile .....nfig/adminpassword.txt --echo=true --terse=false create-cluster sqe-cluster
        01/31/2013 19:25:55 EXIT: 0 asadmin --host localhost --port 4848 --user admin --passwordfile .....nfig/adminpassword.txt --echo=true --terse=false create-local-instance --cluster sqe-cluster --systemproperties HTTP_LISTENER_PORT=38080:HTTP_SSL_LISTENER_PORT=38181:IIOP_SSL_LISTENER_PORT=33800:IIOP_LISTENER_PORT=33700:JMX_SYSTEM_CONNECTOR_PORT=37676:IIOP_SSL_MUTUALAUTH_PORT=33801:JMS_PROVIDER_PORT=38686:ASADMIN_LISTENER_PORT=34848 clustered_instance_1
        01/31/2013 19:25:57 EXIT: 0 asadmin --host localhost --port 4848 --user admin --passwordfile .....nfig/adminpassword.txt --echo=true --terse=false create-local-instance --cluster sqe-cluster --systemproperties HTTP_LISTENER_PORT=48080:HTTP_SSL_LISTENER_PORT=48181:IIOP_SSL_LISTENER_PORT=43800:IIOP_LISTENER_PORT=43700:JMX_SYSTEM_CONNECTOR_PORT=47676:IIOP_SSL_MUTUALAUTH_PORT=43801:JMS_PROVIDER_PORT=48686:ASADMIN_LISTENER_PORT=44848 clustered_instance_2
        01/31/2013 19:25:58 EXIT: 0 asadmin --host localhost --port 4848 --user admin --passwordfile .....nfig/adminpassword.txt --echo=true --terse=false create-local-instance --cluster sqe-cluster --systemproperties HTTP_LISTENER_PORT=58080:HTTP_SSL_LISTENER_PORT=58181:IIOP_SSL_LISTENER_PORT=53800:IIOP_LISTENER_PORT=53700:JMX_SYSTEM_CONNECTOR_PORT=57676:IIOP_SSL_MUTUALAUTH_PORT=53801:JMS_PROVIDER_PORT=58686:ASADMIN_LISTENER_PORT=54848 clustered_instance_3
        01/31/2013 19:26:12 EXIT: 0 asadmin --_auxinput - --interactive=false start-local-instance --node localhost-sqe-domain --sync normal clustered_instance_3
        01/31/2013 19:26:13 EXIT: 0 asadmin --_auxinput - --interactive=false start-local-instance --node localhost-sqe-domain --sync normal clustered_instance_1
        01/31/2013 19:26:13 EXIT: 0 asadmin --_auxinput - --interactive=false start-local-instance --node localhost-sqe-domain --sync normal clustered_instance_2
        01/31/2013 19:26:13 EXIT: 0 asadmin --user admin --passwordfile .....nfig/adminpassword.txt --echo=true --terse=false start-cluster sqe-cluster

        Tom Mueller added a comment -

        The root cause of this is that the ogs-version.properties file is missing the default_domain_template property, so a nucleus domain is being created rather than an appserver domain. This is actually only a problem on the ogs distribution, not the glassfish distribution.

        Tom Mueller added a comment -

        Fixed in revision 59022.

        sherryshen added a comment -

        Verified the fix on ogs-4.0-b73.zip


          People

          • Assignee:
            Tom Mueller
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: