glassfish
  1. glassfish
  2. GLASSFISH-19621 Make glassfish runnable on Knopflerfish again
  3. GLASSFISH-19623

NPE because systemBundle.getBundleContext().getDataFile() returns null on Knopflerfish

    Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b73
    • Component/s: OSGi
    • Labels:
      None

      Description

      ss141213@Sahoo:~/software/knopflerfish_osgi_tiny_3.5.0/osgi$ KNOPFLERFISH_HOME=`pwd` GlassFish_Platform=Knopflerfish java -jar ~/WS/gf/trunk/nucleus/distributions/nucleus/target/stage/nucleus/modules/glassfish.jar
      Launching GlassFish on Knopflerfish platform
      Exception in thread "main" java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
      Caused by: org.glassfish.embeddable.GlassFishException: java.lang.NullPointerException
      at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:169)
      at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157)
      at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112)
      ... 6 more
      Caused by: java.lang.NullPointerException
      at java.io.FileOutputStream.<init>(FileOutputStream.java:206)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:165)
      at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.storeProvisioningOptions(OSGiGlassFishRuntimeBuilder.java:365)
      at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:135)
      ... 9 more
      Error stopping framework: java.lang.NullPointerException
      java.lang.NullPointerException
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher$1.run(GlassFishMain.java:203)

      See https://sourceforge.net/p/gatespace/discussion/328005/thread/b10e7133/#c64d for the reason.

        Activity

        Sanjeeb Sahoo added a comment -

        r59061 | ss141213 | 2013-02-03 20:11:59 +0530 (Sun, 03 Feb 2013) | 2 lines


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: