glassfish
  1. glassfish
  2. GLASSFISH-19659

SEVERE: component referenced from annotation symbol cannot be found symbol: javax.jws.HandlerChain

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.0_b74
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      windows
      NetBeans 7.2.1

      Description

      SEVERE: component referenced from annotation symbol cannot be found
      symbol: javax.jws.HandlerChain
      location: class oprah.oprah

      SAME ISSUE:
      http://stackoverflow.com/questions/8192712/jax-ws-glassfish-and-handlerchain

      --------------------------------------------
      oprah/oprah.java
      --------------------------------------------
      package oprah;

      import javax.jws.HandlerChain;
      import javax.jws.WebMethod;
      import javax.jws.WebParam;
      import javax.jws.WebService;

      @WebService(serviceName = "oprahretina", portName="ServerInfoPort777")
      @HandlerChain(file="handler.xml")
      public class oprah {

      @WebMethod(operationName = "hello")
      public String hello(@WebParam(name = "name") String txt)

      { return "Hello " + txt + " !"; }

      }

      --------------------------------------------
      oprah/handler.xml
      --------------------------------------------
      <?xml version="1.0" encoding="UTF-8"?>
      <handler-chains xmlns="http://java.sun.com/xml/ns/javaee">
      <handler-chain>
      <handler>
      <handler-name>oprah.Hand</handler-name>
      <handler-class>oprah.Hand</handler-class>
      </handler>
      </handler-chain>
      </handler-chains>

      --------------------------------------------
      Hand.java
      --------------------------------------------
      package oprah;

      import java.util.Set;
      import javax.xml.ws.handler.MessageContext;
      import javax.xml.ws.handler.soap.SOAPHandler;

      public class Hand implements SOAPHandler {
      @Override
      public Set getHeaders()

      { return null; }

      @Override
      public boolean handleMessage(MessageContext context)

      { System.out.println("hhhhhhhhhhhhhhhhhhhhhh"); return true; }

      @Override
      public boolean handleFault(MessageContext context)

      { return true; }

      @Override
      public void close(MessageContext context) {
      }
      }

        Issue Links

          Activity

          bugs6891 added a comment -

          Similar issue:

          CONNECT Gateway
          GATEWAY-1104

          HIEM deployment failure with Metro 2.1.1 with component not found errors

          bugs6891 added a comment -

          This part of code is most probalby throwing it:

          package com.sun.enterprise.deployment.annotation.handlers;

          public class HandlerChainHandler extends AbstractHandler {

          HandlerChainContainer[] containers=null;
          if (annCtx instanceof HandlerContext)

          { containers = ((HandlerContext) annCtx).getHandlerChainContainers(serviceSideChain, declaringClass); }

          if (containers==null || containers.length==0)

          { // could not find my web service... throw new AnnotationProcessorException( localStrings.getLocalString( "enterprise.deployment.annotation.handlers.componentnotfound", "component referenced from annotation symbol cannot be found"), annInfo); }

          http://kickjava.com/src/com/sun/enterprise/deployment/annotation/handlers/HandlerChainHandler.java.htm
          Read more: http://kickjava.com/src/com/sun/enterprise/deployment/annotation/handlers/HandlerChainHandler.java.htm#ixzz2KLUlHGlt

          bugs6891 added a comment -

          This SEVERE messages occure during deployement phase.

          Lukas Jungmann added a comment -

          reproduced in 3.1.2.2 but cannot reproduce in latest trunk, so looks like this one is fixed. Can you verify it in some trunk build, please?

          Thanks.

          bugs6891 added a comment -

          I have tested it on:
          GlassFish Server Open Source Edition 3.1.2.2 (build 5)

          Plese tell me if i have done some silly thing.

          and it is still there:

          [#|2013-02-09T20:18:19.733+0100|SEVERE|glassfish3.1.2|global|_ThreadID=87;_ThreadName=Thread-2;|component referenced from annotation symbol cannot be found
          symbol: javax.jws.HandlerChain
          location: class oprah.oprah|#]

          I am not sure in which version is glassfish under development now, or how to get it.

          Lukas Jungmann added a comment -

          promoted builds from trunk are available at http://dlc.sun.com.edgesuite.net/glassfish/4.0/promoted/ latest one at this point is b74, simply grab one called 'latest-'

          bugs6891 added a comment -

          Nice, thank you very much. This helped me a lot.

          (SEVERE|glassfish3.1.2|global|_ThreadID=87;_ThreadName=Thread-2;|component referenced from annotation symbol cannot be found
          symbol: javax.jws.HandlerChain)

          Message has gone. Superb Lukas. Thank you again.

          So I can, definitely say that it is fixed.

          (Can i ask next next begginer question, but i do not want to waste your time:
          It was fixed on:
          GlassFish Server Open Source Edition 4.0 (build 73)

          But it was present here (this is some kind of stable release):
          GlassFish Server Open Source Edition 3.1.2.2 (build 5)

          Is this 4.0 (build 73) version development(beta verion) or some stable(usable)?
          )

          Lukas Jungmann added a comment -

          it could have been fixed earlier

          v 3.1.2.2 is the latest released version, it's based on 3.1.2, I don't know about if next patch release is planned or not but you can get paid support for this codeline if needed

          v 4.0 is upcoming release, currently under development and is planned to be released sometimes this year;
          there are 2 kinds of builds available for it:
          -nightly (~daily) builds: http://dlc.sun.com.edgesuite.net/glassfish/4.0/nightly/
          -promoted (~weekly) builds: http://dlc.sun.com.edgesuite.net/glassfish/4.0/promoted/

          There are also milestones (~4-6weeks), detailed dates are https://wikis.oracle.com/display/GlassFish/4.0BuildSchedule

          wrt stability - promoted builds should be fine to use for development and I'd recommend it, for production - hard to say as some areas are already better than in 3.1.x but others are still under development, so if your app is critical, it's probably better to stick with 3.1.2.2 for now and use v4 for testing

          HTH

          abhi0123 added a comment -

          I'm seeing this on glassfish-4.0-b89 and came across this thread. It is obviously not fixed yet. As others have noted, the handler chain actually gets invoked but that doesn't make the message any less annoying. Will attach working code if someone wants to take a look.

          [2013-11-03T15:44:44.452-0500] [glassfish 4.0] [SEVERE] [] [global] [tid: _ThreadID=36 _ThreadName=admin-listener(5)] [timeMillis: 1383511484452] [levelValue: 1000] [[
            Component referenced from annotation symbol cannot be found
           symbol: javax.jws.HandlerChain
           location: class name.abhijitsarkar.learning.webservices.jaxws.security.ut.CalculatorUT]]
          

          (Also posted on https://java.net/jira/browse/GLASSFISH-16875)


            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              bugs6891
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 3 days
                3d
                Remaining:
                Remaining Estimate - 3 days
                3d
                Logged:
                Time Spent - Not Specified
                Not Specified