glassfish
  1. glassfish
  2. GLASSFISH-19670

Unable to create domain after removing default domain and directory

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0_b74
    • Fix Version/s: 4.0_b77
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Oracle Enterprise Linux 6 system, problem seen on build 73, 74 and 75. JDK 1.7.0_10. Using glassfish-unix.sh distro. Using Silent Installer

      Description

      This issue has broken our automated CLI test suite. The scenario is simple
      1. Install glassfish-unix.sh using silent installer
      2. Start/Stop domain
      3. Remove the default domain
      4. Create a new domain (use default name).

      The problem is that "create-domain" fails and the tests all fail afterwards. The root issue appears that "create-domain" has changed. In the past it created the directory of the domain, but now it does not. This appears to be a regression for us. The exact sequence of steps are:

      SETTING UP DOMAIN FOR SILENT INSTALL... Executing /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/bin/asadmin --user admin --passwordfile - create-domain --template=/export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/common/templates/gf/appserver-domain.jar --savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1
      /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/bin/asadmin --user admin --passwordfile - create-domain --template=/export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/common/templates/gf/appserver-domain.jar --savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1 Using port 4848 for Admin. Using port 8080 for HTTP Instance. Using port 7676 for JMS. Using port 3700 for IIOP. Using port 8181 for HTTP_SSL. Using port 3820 for IIOP_SSL. Using port 3920 for IIOP_MUTUALAUTH. Using port 8686 for JMX_ADMIN. Using default port 6666 for OSGI_SHELL. Using default port 9009 for JAVA_DEBUGGER. Distinguished Name of the self-signed X.509 Server Certificate is: [CN=easqezorro5.us.oracle.com,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US] Distinguished Name of the self-signed X.509 Server Certificate is: [CN=easqezorro5.us.oracle.com-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US] Domain domain1 created. Domain domain1 admin port is 4,848. Domain domain1 allows admin login as user "admin" with no password. Admin login information for host [localhost] and port [4848] is being overwritten with credentials provided because the --savelogin option was used during the create-domain command. Login information relevant to admin user name [admin] for this domain [domain1] stored at [/export/home/hudson/.gfclient/pass] successfully. Make sure that this file remains protected. Information stored in this file will be used by asadmin commands to manage this domain. Command create-domain executed successfully.

      + asadmin start-domain
      Waiting for domain1 to start ........ Successfully started the domain : domain1 domain Location: /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains/domain1 Log File: /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains/domain1/logs/server.log Admin Port: 4848 Command start-domain executed successfully. + asadmin version
      Version = GlassFish Server Open Source Edition 4.0 (build 73) Command version executed successfully. + asadmin stop-domain
      Waiting for the domain to stop . Command stop-domain executed successfully.

      Build 72 - new domain is created and it works
      ----------------------------------------------
      create-default-domain:
      [exec] CLI306: Warning - The server located at /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains/domain1 is not running.
      [exec] Command stop-domain executed successfully.
      [delete] Deleting directory /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains
      [echo] executing: asadmin --user admin --passwordfile /export/home/hudson/workspace/alex-admincli/appserver-sqe/common/admincli/config/runtime/password.txt create-domain --adminport 4848 --savelogin=false domain1
      [exec] Using port 4848 for Admin.
      [exec] Using default port 8080 for HTTP Instance.
      [exec] Using default port 7676 for JMS.
      [exec] Using default port 3700 for IIOP.
      [exec] Using default port 8181 for HTTP_SSL.
      [exec] Using default port 3820 for IIOP_SSL.
      [exec] Using default port 3920 for IIOP_MUTUALAUTH.
      [exec] Using default port 8686 for JMX_ADMIN.
      [exec] Using default port 6666 for OSGI_SHELL.
      [exec] Using default port 9009 for JAVA_DEBUGGER.
      [exec] Distinguished Name of the self-signed X.509 Server Certificate is:
      [exec] [CN=easqezorro5.us.oracle.com,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
      [exec] Distinguished Name of the self-signed X.509 Server Certificate is:
      [exec] [CN=easqezorro5.us.oracle.com-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
      [exec] Found populator: org.glassfish.kernel.embedded.EmbeddedDomainXml
      [exec] Authorization Service has successfully initialized.
      [exec] No domain initializers found, bypassing customization step
      [exec] Domain domain1 created.
      [exec] Domain domain1 admin port is 4,848.
      [exec] Domain domain1 allows admin login as user "admin" with no password.
      [exec] Command create-domain executed successfully.

      Build 73, 74 or 75 - new domain fails
      -------------------------------------

      create-default-domain:

      [exec] CLI306: Warning - The server located at /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains/domain1 is not running.
      [exec] Command stop-domain executed successfully.
      [delete] Deleting directory /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains
      [echo] executing: asadmin --user admin --passwordfile /export/home/hudson/workspace/alex-admincli/appserver-sqe/common/admincli/config/runtime/password.txt create-domain --adminport 4848 --savelogin=false domain1
      [exec] /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains is not a directory( com.sun.enterprise.admin.servermgmt.InvalidConfigException: /export/home/hudson/workspace/alex-admincli/glassfish3/glassfish/domains is not a directory )
      [exec] CLI130: Could not create domain, domain1
      [exec] Command create-domain failed.
      [exec] Result: 1

        Activity

        Tom Mueller added a comment -

        Alok, it appears as part of the template JAR changes, the creation of the --domaindir directory was deleted.

        Alex Pineda added a comment -

        This bug is blocking our ability to execute our AdminCLI automated tests on JavaEE 7. Please resolve this issue as soon as you can.

        Alex Pineda added a comment -

        Verified fix in build 77. Works. Able to start the testing. Not blocked any longer. Please update the bug as fixed.

        Alok Jain added a comment -

        Creating a domain directory if dir do not exist at a time of domain creation. Bug has been verified in build # 77 refer above comment from Alex.


          People

          • Assignee:
            Alok Jain
            Reporter:
            Alex Pineda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: