Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b76_EE7MS5
    • Fix Version/s: 4.0_b77
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      OEL6

    • Status Whiteboard:

      Request issue be resolved in GF 4.0 release.

      Show
      Request issue be resolved in GF 4.0 release.

      Description

      Build :GlassFish Server Open Source Edition 4.0 B76

      Steps to reproduce :

      1) Install GF4.0 B76
      2) Check for asadmin version -v
      Its will display the extra characters "$

      {version_suffix}" on the console.

      # ./asadmin version -v
      Version = GlassFish Server Open Source Edition 4.0 ${version_suffix}

      (build 76), JRE version 1.7.0-internal
      Command version executed successfully.

      You can also see this issue on Admin console.
      Login to admin console and click on version tab , you can see the issue.

        Issue Links

          Activity

          Snjezana Sevo-Zenzerovic added a comment -

          Moving to appropriate subcomponent for evaluation.

          Tom Mueller added a comment -

          This problem is seen in the promoted builds. For example:
          http://javaweb.us.oracle.com/java/re/glassfish/4.0/promoted/b76/archive/bundles/glassfish-4.0-b76.zip

          The problem is in the glassfish/config/branding/glassfish-version.properties file where the version_suffix property is not being substituted at build time:

          version_suffix=$

          {version_suffix}

          This problem does not happen on the continuous builds.

          The way this is supposed to work is that the packager/appserver-base package does a filtering substitution on the resources, including the glassfish-version.properties file. The version_suffix property is defined in the appserver/pom.xml file.

          For the official build, this value is not being set properly.

          Romain Grécourt added a comment -
          romano@dhcp-prague08-third-floor-10-163-25-212:~/Downloads/glassfish4/glassfish$ bin/asadmin version
          Version string could not be obtained from Server [localhost:4848].
          (Turn debugging on e.g. by setting AS_DEBUG=true in your environment, to see the details.)
          Using locally retrieved version string from version class.
          Version = GlassFish Server Open Source Edition  4.0  (build 77)
          Command version executed successfully.
          
          romano@dhcp-prague08-third-floor-10-163-25-212:~/Downloads/glassfish4/glassfish$ bin/asadmin start-domain
          Waiting for domain1 to start .......
          Successfully started the domain : domain1
          domain  Location: /Users/romano/Downloads/glassfish4/glassfish/domains/domain1
          Log File: /Users/romano/Downloads/glassfish4/glassfish/domains/domain1/logs/server.log
          Admin Port: 4848
          Command start-domain executed successfully.
          
          romano@dhcp-prague08-third-floor-10-163-25-212:~/Downloads/glassfish4/glassfish$ bin/asadmin version
          Version = GlassFish Server Open Source Edition  4.0  (build 77)
          Command version executed successfully.
          

            People

            • Assignee:
              Romain Grécourt
              Reporter:
              bhavya_h_s
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: