glassfish
  1. glassfish
  2. GLASSFISH-19693

SEVERE: Exception during lifecycle processing org.glassfish.deployment.common.DeploymentException: CDI deployment failure:Error loading class servlets.Servlet1

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b76_EE7MS5
    • Fix Version/s: None
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      Description

      I'm not able to deploy sample JMS2.0 project onto Glassfish because the exception mentioned below. The code looks well to me and form the exception it just seems to me that something around CDI in GlassFish4 failed.

      Link to the application:
      http://java.net/projects/jms-spec/downloads/download/JMS20Demo.zip

      Server output:
      SEVERE: Class [ Lbeans/JavaEESenderNew; ] not found. Error while loading [ class servlets.Servlet1 ]
      SEVERE: Class [ Lbeans/JavaEESenderNew; ] not found. Error while loading [ class servlets.Servlet1 ]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESyncReceiverNewCDI: [java:global/JMS20Demo/JavaEESyncReceiverNewCDI, java:global/JMS20Demo/JavaEESyncReceiverNewCDI!beans.JavaEESyncReceiverNewCDI]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESenderOld: [java:global/JMS20Demo/JavaEESenderOld, java:global/JMS20Demo/JavaEESenderOld!beans.JavaEESenderOld]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESyncReceiverNewCDIWithProperties: [java:global/JMS20Demo/JavaEESyncReceiverNewCDIWithProperties!beans.JavaEESyncReceiverNewCDIWithProperties, java:global/JMS20Demo/JavaEESyncReceiverNewCDIWithProperties]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESenderNewCDI: [java:global/JMS20Demo/JavaEESenderNewCDI, java:global/JMS20Demo/JavaEESenderNewCDI!beans.JavaEESenderNewCDI]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESyncReceiverOld: [java:global/JMS20Demo/JavaEESyncReceiverOld!beans.JavaEESyncReceiverOld, java:global/JMS20Demo/JavaEESyncReceiverOld]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESenderNewCDIWithProperties: [java:global/JMS20Demo/JavaEESenderNewCDIWithProperties, java:global/JMS20Demo/JavaEESenderNewCDIWithProperties!beans.JavaEESenderNewCDIWithProperties]
      INFO: EJB5181:Portable JNDI names for EJB JavaEESenderOldWithProperties: [java:global/JMS20Demo/JavaEESenderOldWithProperties, java:global/JMS20Demo/JavaEESenderOldWithProperties!beans.JavaEESenderOldWithProperties]
      SEVERE: Exception during lifecycle processing
      org.glassfish.deployment.common.DeploymentException: CDI deployment failure:Error loading class servlets.Servlet1
      at org.glassfish.weld.WeldDeployer.event(WeldDeployer.java:203)
      at org.glassfish.kernel.event.EventsImpl.send(EventsImpl.java:131)
      at org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:303)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:493)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:219)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:491)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:528)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:524)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAs(Subject.java:356)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:523)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:547)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1424)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1500(CommandRunnerImpl.java:108)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1759)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1675)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:534)
      at com.sun.enterprise.v3.admin.AdminAdapter.onMissingResource(AdminAdapter.java:224)
      at org.glassfish.grizzly.http.server.StaticHttpHandler.service(StaticHttpHandler.java:297)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
      at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:175)
      at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:273)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
      at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:820)
      at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: org.jboss.weld.resources.spi.ResourceLoadingException: Error loading class servlets.Servlet1
      at org.jboss.weld.resources.ClassTransformer.loadClass(ClassTransformer.java:167)
      at org.jboss.weld.manager.BeanManagerImpl.createAnnotatedType(BeanManagerImpl.java:1026)
      at org.glassfish.weld.WeldDeployer.firePITEvent(WeldDeployer.java:385)
      at org.glassfish.weld.WeldDeployer.fireProcessInjectionTargetEvents(WeldDeployer.java:357)
      at org.glassfish.weld.WeldDeployer.event(WeldDeployer.java:194)
      ... 35 more
      Caused by: java.lang.NoClassDefFoundError: Lbeans/JavaEESenderNew;
      at java.lang.Class.getDeclaredFields0(Native Method)
      at java.lang.Class.privateGetDeclaredFields(Class.java:2308)
      at java.lang.Class.getDeclaredFields(Class.java:1760)
      at org.jboss.weld.util.reflection.SecureReflections$4.work(SecureReflections.java:105)
      at org.jboss.weld.util.reflection.SecureReflections$4.work(SecureReflections.java:102)
      at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52)
      at org.jboss.weld.util.reflection.SecureReflectionAccess.runAndWrap(SecureReflectionAccess.java:63)
      at org.jboss.weld.util.reflection.SecureReflections.getDeclaredFields(SecureReflections.java:102)
      at org.jboss.weld.introspector.jlr.WeldClassImpl.<init>(WeldClassImpl.java:155)
      at org.jboss.weld.introspector.jlr.WeldClassImpl.of(WeldClassImpl.java:121)
      at org.jboss.weld.resources.ClassTransformer$TransformTypeToWeldClass.apply(ClassTransformer.java:59)
      at org.jboss.weld.resources.ClassTransformer$TransformTypeToWeldClass.apply(ClassTransformer.java:50)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingValueReference.compute(ComputingConcurrentHashMap.java:355)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingSegment.compute(ComputingConcurrentHashMap.java:184)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingSegment.getOrCompute(ComputingConcurrentHashMap.java:153)
      at com.google.common.collect.ComputingConcurrentHashMap.getOrCompute(ComputingConcurrentHashMap.java:69)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingMapAdapter.get(ComputingConcurrentHashMap.java:393)
      at org.jboss.weld.resources.ClassTransformer.loadClass(ClassTransformer.java:163)
      ... 39 more
      Caused by: java.lang.ClassNotFoundException: beans.JavaEESenderNew
      at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1729)
      at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1579)
      ... 57 more

      SEVERE: Exception while loading the app
      SEVERE: Undeployment failed for context /JMS20Demo
      WARNING: JCDI shutdown error
      java.lang.IllegalStateException: Singleton not set for WebappClassLoader (delegate=true)
      at org.glassfish.weld.ACLSingletonProvider$ACLSingleton.get(ACLSingletonProvider.java:110)
      at org.jboss.weld.Container.instance(Container.java:54)
      at org.jboss.weld.bootstrap.WeldBootstrap.shutdown(WeldBootstrap.java:466)
      at org.glassfish.weld.WeldDeployer.event(WeldDeployer.java:288)
      at org.glassfish.kernel.event.EventsImpl$1.run(EventsImpl.java:123)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)
      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)

      SEVERE: Exception while loading the app : CDI deployment failure:Error loading class servlets.Servlet1
      org.jboss.weld.resources.spi.ResourceLoadingException: Error loading class servlets.Servlet1
      at org.jboss.weld.resources.ClassTransformer.loadClass(ClassTransformer.java:167)
      at org.jboss.weld.manager.BeanManagerImpl.createAnnotatedType(BeanManagerImpl.java:1026)
      at org.glassfish.weld.WeldDeployer.firePITEvent(WeldDeployer.java:385)
      at org.glassfish.weld.WeldDeployer.fireProcessInjectionTargetEvents(WeldDeployer.java:357)
      at org.glassfish.weld.WeldDeployer.event(WeldDeployer.java:194)
      at org.glassfish.kernel.event.EventsImpl.send(EventsImpl.java:131)
      at org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:303)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:493)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:219)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:491)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:528)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:524)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAs(Subject.java:356)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:523)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:547)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1424)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1500(CommandRunnerImpl.java:108)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1759)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1675)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:534)
      at com.sun.enterprise.v3.admin.AdminAdapter.onMissingResource(AdminAdapter.java:224)
      at org.glassfish.grizzly.http.server.StaticHttpHandler.service(StaticHttpHandler.java:297)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
      at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:175)
      at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:273)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
      at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:820)
      at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.NoClassDefFoundError: Lbeans/JavaEESenderNew;
      at java.lang.Class.getDeclaredFields0(Native Method)
      at java.lang.Class.privateGetDeclaredFields(Class.java:2308)
      at java.lang.Class.getDeclaredFields(Class.java:1760)
      at org.jboss.weld.util.reflection.SecureReflections$4.work(SecureReflections.java:105)
      at org.jboss.weld.util.reflection.SecureReflections$4.work(SecureReflections.java:102)
      at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52)
      at org.jboss.weld.util.reflection.SecureReflectionAccess.runAndWrap(SecureReflectionAccess.java:63)
      at org.jboss.weld.util.reflection.SecureReflections.getDeclaredFields(SecureReflections.java:102)
      at org.jboss.weld.introspector.jlr.WeldClassImpl.<init>(WeldClassImpl.java:155)
      at org.jboss.weld.introspector.jlr.WeldClassImpl.of(WeldClassImpl.java:121)
      at org.jboss.weld.resources.ClassTransformer$TransformTypeToWeldClass.apply(ClassTransformer.java:59)
      at org.jboss.weld.resources.ClassTransformer$TransformTypeToWeldClass.apply(ClassTransformer.java:50)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingValueReference.compute(ComputingConcurrentHashMap.java:355)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingSegment.compute(ComputingConcurrentHashMap.java:184)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingSegment.getOrCompute(ComputingConcurrentHashMap.java:153)
      at com.google.common.collect.ComputingConcurrentHashMap.getOrCompute(ComputingConcurrentHashMap.java:69)
      at com.google.common.collect.ComputingConcurrentHashMap$ComputingMapAdapter.get(ComputingConcurrentHashMap.java:393)
      at org.jboss.weld.resources.ClassTransformer.loadClass(ClassTransformer.java:163)
      ... 39 more
      Caused by: java.lang.ClassNotFoundException: beans.JavaEESenderNew
      at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1729)
      at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1579)
      ... 57 more

        Activity

        marfous added a comment -

        I'm not able to reproduce the issue with the GF4.0.b76 and GF4.0.b77 today but I was definitely able to do so repeatedly yesterday (also after GF restarts).
        It's strange to me and I'm keeping it at least for the log evaluation. Thanks.

        jjsnyder83 added a comment -

        Based on the exception trace it looks like CDI Failed because of some DD problem that appears to have been fixed because the failure cannot be reproduced.


          People

          • Assignee:
            jjsnyder83
            Reporter:
            marfous
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: