glassfish
  1. glassfish
  2. GLASSFISH-19709

The windows version installer doesn't detect the JVM, and failed to start the installer.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0_b77
    • Fix Version/s: 4.0
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Windows 7 SP1
      Java SE 6 u41
      Java SE 7 u15

      Description

      1- I have downloaded Glassfish, windows version glassfish-4.0-b77-windows-ml.
      2- I have 2 versions of JDK version 6_u41 and 7_u15.
      3- Click the installer, it will popup a setup error message as the following:

      "This application needs version 1.6 or higher of the Java(TM) 2 runtime Environment..... etc."

      It should detect already existing JVM version, which installed normally.

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        I will consolidate this issue with GLASSFISH-19877 which has the same root cause. Native install wrapper does have issues with reliable 64 bit JDK detection on Windows platforms.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: