glassfish
  1. glassfish
  2. GLASSFISH-19712

IllegalArgumentException from ClassLoader.definePackage

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b77
    • Fix Version/s: 4.0_b81
    • Component/s: classloader
    • Labels:
      None
    • Environment:

      Mac OS or Solaris x86

      Description

      The admin devtests are periodically seeing failures that result in the inability to fetch the index.html page from an instance. This typically happens once or twice in every run of the admin devtest hudson job. See:
      http://hudson-sca.us.oracle.com/job/admin-devtests-trunk/

      I recreated this problem locally on MacOS by using a manual run of just the cluster tests. I stopped the test after the failure so I could see what was happening. The log messages below showed up in the server.log file. These seem to indicate some sort of problem with starting the web container.

      I don't know if these exceptions are what are causing the failure to serve static HTML pages.

      The behavior of the instance when it gets into this state is as follows:

      $ curl -v http://localhost:18080/

      • About to connect() to localhost port 18080 (#0)
      • Trying ::1...
      • connected
      • Connected to localhost (::1) port 18080 (#0)
        > GET / HTTP/1.1
        > User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0 OpenSSL/0.9.8r zlib/1.2.5
        > Host: localhost:18080
        > Accept: /
        >
        < HTTP/1.1 500 Internal Server Error
        < X-Powered-By: Servlet/3.0 JSP/2.2 (GlassFish Server Open Source Edition 4.0 Java/Oracle Corporation/1.7)
        < Server: GlassFish Server Open Source Edition 4.0
        < Content-Language:
        < Content-Type: text/html
        < Date: Fri, 22 Feb 2013 01:57:24 GMT
        < Connection: close
        < Content-Length: 0
        <
      • Closing connection #0

      [#|2013-02-21T19:00:42.480-0600|SEVERE|glassfish 4.0|javax.enterprise.web.core|_ThreadID=1;_ThreadName=main;_TimeMillis=1361494842480;_LevelValue=1000;_MessageID=AS-WEB-CORE-00113;|Startup of context failed due to previous errors|#]

      [#|2013-02-21T19:00:42.482-0600|SEVERE|glassfish 4.0|javax.enterprise.web.core|_ThreadID=1;_ThreadName=main;_TimeMillis=1361494842482;_LevelValue=1000;_MessageID=AS-WEB-CORE-00114;|Exception during cleanup after start failed
      org.apache.catalina.LifecycleException: Manager has not yet been started
      at org.apache.catalina.session.StandardManager.stop(StandardManager.java:934)
      at org.apache.catalina.core.StandardContext.stop(StandardContext.java:6092)
      at com.sun.enterprise.web.WebModule.stop(WebModule.java:725)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:5909)
      at com.sun.enterprise.web.WebModule.start(WebModule.java:696)
      at org.apache.catalina.core.ContainerBase.startChildren(ContainerBase.java:1593)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1290)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:982)
      at org.apache.catalina.core.ContainerBase.startChildren(ContainerBase.java:1593)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1290)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:402)
      at org.apache.catalina.startup.Embedded.start(Embedded.java:993)
      at com.sun.enterprise.web.WebContainer.postConstruct(WebContainer.java:867)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:264)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:306)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:433)
      at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:87)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2099)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at org.glassfish.internal.data.EngineInfo.getContainer(EngineInfo.java:86)
      at org.glassfish.kernel.javaee.WebContainerStarter.startWebContainer(WebContainerStarter.java:241)
      at org.glassfish.kernel.javaee.WebContainerStarter.postConstruct(WebContainerStarter.java:180)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:264)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:306)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:433)
      at org.glassfish.hk2.runlevel.internal.RunLevelContext.findOrCreate(RunLevelContext.java:119)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2099)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at com.sun.enterprise.v3.server.AppServerStartup$StartupActivator.activate(AppServerStartup.java:516)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$Worker.activateRunLevel(RunLevelControllerImpl.java:820)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$Worker.upActiveRecorder(RunLevelControllerImpl.java:776)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$Worker.run(RunLevelControllerImpl.java:671)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$SyncProceedToWorker.proceedTo(RunLevelControllerImpl.java:938)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl.proceedTo(RunLevelControllerImpl.java:577)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl.proceedTo(RunLevelControllerImpl.java:351)
      at com.sun.enterprise.v3.server.AppServerStartup.proceedTo(AppServerStartup.java:381)
      at com.sun.enterprise.v3.server.AppServerStartup.run(AppServerStartup.java:255)
      at com.sun.enterprise.v3.server.AppServerStartup.doStart(AppServerStartup.java:173)
      at com.sun.enterprise.v3.server.AppServerStartup.start(AppServerStartup.java:164)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishImpl.start(GlassFishImpl.java:79)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.start(GlassFishDecorator.java:63)
      at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl.start(EmbeddedOSGiGlassFishImpl.java:75)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.start(GlassFishDecorator.java:63)
      at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishImpl.start(OSGiGlassFishImpl.java:71)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:117)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)

      #]

      [#|2013-02-21T19:00:42.483-0600|SEVERE|glassfish 4.0|javax.enterprise.web.core|_ThreadID=1;_ThreadName=main;_TimeMillis=1361494842483;_LevelValue=1000;|Container StandardEngine[glassfish-web].StandardHost[server].StandardContext[] has not been started
      org.apache.catalina.LifecycleException: java.lang.IllegalArgumentException: com.sun.xml.ws.transport.http.servlet
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:5913)
      at com.sun.enterprise.web.WebModule.start(WebModule.java:696)
      at org.apache.catalina.core.ContainerBase.startChildren(ContainerBase.java:1593)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1290)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:982)
      at org.apache.catalina.core.ContainerBase.startChildren(ContainerBase.java:1593)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1290)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:402)
      at org.apache.catalina.startup.Embedded.start(Embedded.java:993)
      at com.sun.enterprise.web.WebContainer.postConstruct(WebContainer.java:867)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:264)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:306)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:433)
      at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:87)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2099)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at org.glassfish.internal.data.EngineInfo.getContainer(EngineInfo.java:86)
      at org.glassfish.kernel.javaee.WebContainerStarter.startWebContainer(WebContainerStarter.java:241)
      at org.glassfish.kernel.javaee.WebContainerStarter.postConstruct(WebContainerStarter.java:180)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:264)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:306)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:433)
      at org.glassfish.hk2.runlevel.internal.RunLevelContext.findOrCreate(RunLevelContext.java:119)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2099)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at com.sun.enterprise.v3.server.AppServerStartup$StartupActivator.activate(AppServerStartup.java:516)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$Worker.activateRunLevel(RunLevelControllerImpl.java:820)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$Worker.upActiveRecorder(RunLevelControllerImpl.java:776)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$Worker.run(RunLevelControllerImpl.java:671)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl$SyncProceedToWorker.proceedTo(RunLevelControllerImpl.java:938)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl.proceedTo(RunLevelControllerImpl.java:577)
      at org.glassfish.hk2.runlevel.utilities.RunLevelControllerImpl.proceedTo(RunLevelControllerImpl.java:351)
      at com.sun.enterprise.v3.server.AppServerStartup.proceedTo(AppServerStartup.java:381)
      at com.sun.enterprise.v3.server.AppServerStartup.run(AppServerStartup.java:255)
      at com.sun.enterprise.v3.server.AppServerStartup.doStart(AppServerStartup.java:173)
      at com.sun.enterprise.v3.server.AppServerStartup.start(AppServerStartup.java:164)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishImpl.start(GlassFishImpl.java:79)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.start(GlassFishDecorator.java:63)
      at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl.start(EmbeddedOSGiGlassFishImpl.java:75)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.start(GlassFishDecorator.java:63)
      at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishImpl.start(OSGiGlassFishImpl.java:71)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:117)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
      Caused by: java.lang.IllegalArgumentException: com.sun.xml.ws.transport.http.servlet
      at java.lang.ClassLoader.definePackage(ClassLoader.java:1601)
      at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2190)
      at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1472)
      at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
      at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1923)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      at org.apache.felix.framework.BundleWiringImpl.getClassByDelegation(BundleWiringImpl.java:1357)
      at org.apache.felix.framework.BundleWiringImpl.searchDynamicImports(BundleWiringImpl.java:1598)
      at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1479)
      at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
      at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1923)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1832)
      at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:937)
      at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$4$1.run(OSGiModuleImpl.java:434)
      at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$4$1.run(OSGiModuleImpl.java:431)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$4.loadClass(OSGiModuleImpl.java:431)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      at com.sun.enterprise.v3.server.APIClassLoaderServiceImpl$APIClassLoader.loadClass(APIClassLoaderServiceImpl.java:238)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:410)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
      at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1579)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:264)
      at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:363)
      at java.util.ServiceLoader$1.next(ServiceLoader.java:445)
      at org.glassfish.web.loader.ServletContainerInitializerUtil.getInterestList(ServletContainerInitializerUtil.java:193)
      at org.apache.catalina.core.StandardContext.callServletContainerInitializers(StandardContext.java:5955)
      at com.sun.enterprise.web.WebModule.callServletContainerInitializers(WebModule.java:779)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:5888)
      ... 47 more

      #]

      [#|2013-02-21T19:00:42.486-0600|INFO|glassfish 4.0|javax.enterprise.system.core.ee|_ThreadID=1;_ThreadName=main;_TimeMillis=1361494842486;_LevelValue=800;_MessageID=AS-CORE-JAVAEE-0002;|Done with starting web container.|#]

        Activity

        Tom Mueller added a comment -

        Any update on when a new felix with the fix can be integrated? This is still causing periodic admin devtest failures (3 out of the last 23). Thanks.

        Sanjeeb Sahoo added a comment -

        I am working with Felix community and I expect a release to be out by early next week. So, I say we can see this bug fixed by late next week.

        Tom Mueller added a comment -

        Sahoo reported seeing the behavior caused by this bug in the appserver quicklook tests too.

        Amy Roh added a comment -

        FWIW, I am able to see the same behavior from deploying a simple single war file from time to time.

        Sanjeeb Sahoo added a comment -

        Integrated Felix 4.2.1 in svn #60459 to fix this issue.


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            Tom Mueller
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: