glassfish
  1. glassfish
  2. GLASSFISH-19721

Win. Deployment with --name failed, because of the previous undeployment

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b77
    • Fix Version/s: 4.0
    • Component/s: deployment
    • Labels:
      None

      Description

      Win 7.

      Deploy/undeploy an application then deployed the same app with --contextroot temp --name qwerty1. But this deployment failed with the messages:

      remote failure: Error occurred during deployment: Exception while deploying the app [qwerty1] : Invalid ejb jar qwerty1: it contains zero ejb. A valid ejb jar requires at least one session/entity/message driven bean.. Please see server.log for more details.
      Command deploy failed.

      This issue happened only on Windows with two similar apps. I believe that probably previous undeployment case this problem. I've attached one such app.

        Activity

        aelena added a comment -

        I'm trying to create a narrow case. Usually this window problem happened, because different archives were deployed with the same --name. And some undeployment did not release all classes. So I'm trying to find what undeployment created this issue.

        Jeremy_Lv added a comment -

        aelena:
        OK, please take a look about the test. If it can be reproduced as manual, you can describe the exact steps so that I can look into this issue.

        aelena added a comment -

        Can not reproduce this issue, using the latest build. So I'm closing the bug.

        aelena added a comment -

        Please close this bug.

        Hong Zhang added a comment -

        Thanks Elena for the update. Closing the bug.


          People

          • Assignee:
            Hong Zhang
            Reporter:
            aelena
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: