glassfish
  1. glassfish
  2. GLASSFISH-19818

Java ee sdk 7 b78 Installation on linux fails th error

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b78
    • Fix Version/s: 4.0_b79
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Linux

      Description

      Installation of Java EE SDK 7 b78 fails with below error.

      $ sh java_ee_sdk-7-b78-jdk7-linux.sh
      java_ee_sdk-7-b78-jdk7-linux.sh: line 1: PK: command not found
      java_ee_sdk-7-b78-jdk7-linux.sh: line 2: \ufffdvfB: command not found
      java_ee_sdk-7-b78-jdk7-linux.sh: line 3: syntax error near unexpected
      token
      `XcMETA-INF/MANIFEST.MF\ufffdM\ufffd\ufffdLK-\ufffd\ufffd\u03f3R0\ufffd3\ufffd\ufffdr\ufffdCq,HL\ufffdHU\ufffd%\ufffd\ufffdLy\ufffd\ufffd\ufffdRKRSt\ufffd\ufffd\ufffd\ufffd\ufffdLu\ufffd
      \ufffd4\ufffd\ufffd\ufffdsR\ufffd\ufffd\ufffd'
      K-\ufffd\ufffd\u03f3R0\ufffd3\ufffd\ufffdr\ufffdCq,HL\ufffdHU\ufffd%\ufffd\ufffdLy\ufffd\ufffd\ufffdRKRSt\ufffd\ufffd\ufffd\ufffd\ufffdLu\ufffdXcMETA-INF/MANIFEST.MF\ufffdM\ufffd\ufffdLK-.
      \ufffd4\ufffd\ufffd\ufffdsR\ufffd\ufffd\ufffd'

        Activity

        Romain Grécourt added a comment -

        reproduced. The extracting script is missing at the begining of the file.

        Snjezana Sevo-Zenzerovic added a comment -

        Intermediate build artifact has been published instead of the final installer bundle for affected JDK cobundles due to a typo in the bundle name. Fix has been checked in, will be available in Java EE 7 SDK b79 promotion.

        Snjezana Sevo-Zenzerovic added a comment -

        Java EE SDK build with the fix has been promoted, marking the issue as resolved.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            bhavya_h_s
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: