Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b80_EE7MS6
    • Fix Version/s: 4.0_b85
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      N/A

      Description

      /appserver/distributions/glassfish/target/dependency/glassfish4/glassfish/config/branding/glassfish-version.properties contains "BG Server" as the product name property. This appears in the browser when booting the admin console "Starting BG Server 4.0". This should be changed, likely to "GlassFish Server Open Source Edition" if this belongs to the open source branding module.

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        I think we'll need to add branding module which will override branding properties file to appserver workspace. I'll try to get this in by b83.

        Snjezana Sevo-Zenzerovic added a comment -
        • What is the impact on the customer of the bug?

        Regression compared to previous releases and significant branding issue.

        • What is the cost/risk of fixing the bug?

        Low/moderate risk. Very limited impact on product runtime, but fix does span multiple components (need to create appserver specific branding fragment module with appropriate values and integrate that module into packager).

        • Is there an impact on documentation or message strings?

        No.

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Admin GUI visual verification, possibly asadmin version subcommand regression testing.

        • Which is the targeted build of 4.0 for this fix?

        b85

        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.

        N/A

        Tom Mueller added a comment - - edited

        I'm not seeing this in my private builds. The content of the glassfish-version.properties file is:

        product_name=GlassFish Server Open Source Edition
        brief_product_name=GlassFish Server
        abbrev_product_name=glassfish
        major_version=4
        minor_version=0
        update_version=
        build_id=tomuell-private
        version_prefix=
        version_suffix=
        default_domain_template=appserver-domain.jar
        admin_client_command_name=asadmin

        The source file (appserver/packager/appserver-base/src/main/resources/config/branding/glassfish-version.properties) has:

        product_name=$

        {product.name}

        brief_product_name=$

        {brief_product_name}

        abbrev_product_name=$

        {abbrev_product_name}

        major_version=$

        {major_version}

        minor_version=$

        {minor_version}

        update_version=$

        {update_version}

        build_id=$

        {build.id}

        version_prefix=$

        {version_prefix}

        version_suffix=$

        {version_suffix}

        default_domain_template=$

        {default_domain_template}

        admin_client_command_name=$

        {admin_client_command_name}

        Product name is set to GlassFish in the appserver/pom.xml file:

        <product.name>GlassFish Server Open Source Edition</product.name>

        Is this product name being overridden by the build system somewhere?

        Tom Mueller added a comment -

        A fix for this issue is approved for 4.0. However, it appears that more analysis is required to understand where the problem actually is.

        Also, the distribution that actually has this should be identified (the description doesn't do this).

        jclingan added a comment -

        Tom, I pull this from svn directly:

        svn checkout https://svn.java.net/svn/glassfish~svn/trunk/main

        I wasn't sure if this was leaking into another build, and that makes it a P1. Regardless, BG Server shouldn't exist anywhere in the trunk, and that would be a P2.

        Snjezana Sevo-Zenzerovic added a comment -

        This turned out to be a red herring of a sort. So far we are unable to reproduce this with any of RE produced builds or with two developer build setups (Tom's and mine). So, closing as non-reproducible.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            jclingan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: